I would like to change the type of disk form :

  15. c2t15d0 <Sun-STK RAID INT-V1.0 cyl 36417 alt 2 hd 255 sec 63>


  15. c2t15d0 <Sun-STK RAID INT-V1.0-278.99GB>

I tried several type in format command or copied partition table no issue. I encountered this problem on this disk

fdisk /dev/rdsk/c2t15d0
fdisk: Cannot stat device /dev/rdsk/c2t15d0.

The other disk doesn't have any problem with the fdisk command applied directly

Thanks for help

  • Are you sure the disk is actually connected/available? What happens if you try something like dd if=/dev/dsk/c2t15d0 of=/dev/null as root? Mar 7, 2017 at 16:07
  • Which version of Solaris? Mar 7, 2017 at 22:58
  • Solaris 10 with zfs
    – dubis
    Mar 8, 2017 at 8:19
  • SPARC or x86? For the most part they're identical, but handling of drives is different. Mar 16, 2017 at 0:59

1 Answer 1


Sounds like a stale device link.

You don't note your version of Solaris. Usually a devfsadm -Cv will rebuild the tree and clean out any invalid links.

Although, now after rereading your question, I'm wondering if you want to see the "... 278.99GB" in format vs "... cyl, hd, and sec"? If so, I believe it needs to have an EFI label.

Also after re-reading, noticed that you left off the slice in your fdisk commands.

NOTE/WARNING: Changing between a SMI and EFI label can result in data loss. You'll want to read up on the differences, and maybe test on another system prior to making the change using format -e.

  • There's also a diskinfo command which may be of use. Mar 7, 2017 at 22:57
  • Yes I applied the EFI label with fdisk but no issue as fdisk want a number of partition. When I dared to add my disk in the zfs spare, the label has been written and the disk has got its EFI label. the problem has been solved without more explanation
    – dubis
    Mar 8, 2017 at 8:19
  • @dubis Not sure I fully follow. When you use the whole disk with a zpool command, zfs will label it with an EFI label and use the whole drive. I'm also begining to suspect your using the x86 version of Solaris. Mar 16, 2017 at 0:57
  • I didn't repond your ask as IWas not notified Yes I'm using X86 so you're right. EFI on SPARK mother board is it possible ? Sound odd
    – dubis
    Mar 16, 2017 at 9:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .