8

I would like to know that is it possible to use Android studio in FreeBSD ? I tried to run it but I couldn't.I installed IntelliJ from ports but there was no option to select the Android SDK.

2 Answers 2

5

When Android Studio was still in Beta, I tried to get it running on FreeBSD (my preferred platform) but had nothing but issues.

I did manage to compile a debug APK but could not get a full release version (weird). I ran Android Studio under Linux Emulation but there was still issues with the Java side of things (from memory).

I even wrote a complex script for adb to help install the APKs as they would not install from the "Run" option of Android Studio. Not hard, but did speed things up a lot.

In the end I gave up and tried a heap of Linux distro (Live CDs) until I found one I was comfortable with - then installed Android Studio without issues.

Personally I still prefer FreeBSD for a lot of things but I am more than happy with a stable working environment for Android development.

Not the answer you were looking for I know, just sharing my own experience. I guess things could have changed from the Beta to now (v2.3) - but I've decided that Android Studio is updated so often (too often to be honest) that I'm not going to risk issues with FreeBSD and just run Linux.

2
  • Which Linux distro did you choose coming from FreeBSD?
    – serv-inc
    Aug 3, 2018 at 17:16
  • 1
    @serv-inc : There are a lot of Linux distributions and I tried at least 8 before deciding which to go with. In the end I settled on Linux Mint as it felt like a Desktop environment first and foremost.
    – Tigger
    Aug 4, 2018 at 0:02
3

For me it works including native code. Had to hack the starter script a bit with JAVA_HOME etc.

Most of Android SDK etc. has to be downloaded manually and installed under the right directory.

One thing which is not working is aapt2, so I have to add android.enableAapt2=false to gradle.properties.

Now I can't update to the latest gradle version as it demands aapt2.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .