I'm new to Linux environment. Few days ago I've installed Fedora on my laptop. I want to complie some C++ source code but having trouble with Clang. First, after installing it with yum I see an error (whenever I call clang in the console):

clang: symbol lookup error: clang: undefinied symbol: LLVMInitializeMipsAsmParser

After trying different methods I gave up on installing Clang and wanted to stick to g++. OK. but today I wanted to install some IDE. Decided to go with CodeLite and... whenever I want to open CodeLite it gives me this error:

/lib64/libclang.so.3.8: undefined symbol: LLVMInitializeMipsAsmParser

Seems like CodeLite is installing Clang by default and I ending up with the same error...

To be honest I've tried to build LLVM from source but that didn't help (I guess Clang has to know somehow where to look for those symbols and I don't know how to tell it) and I don't have enough disc space to build LLVM & Clang at the same time (it takes 20+ GB...) following instructions from here: http://llvm.org/docs/GettingStarted.html#getting-started-quickly-a-summary


Happened the same to me, after updating clang from 3.8.0 to 3.8.1.

I installed the latest llvm library and it worked :)

dnf install llvm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.