1

I had Ubuntu 16.10 and Windows (ubuntu's grub as bootloader) on my laptop, yesterday I decided to install Kali with it too, so I shrank the Windows 10 partition of 60 gb and filled the created space with kali, I installed kali's version of grub.

The problem is that Ubuntu's booting screen (the purple screen with the ubuntu sign and the 5 dots) was pretty slow. At one point it passed from the normal purple coloration to a darker purple, and it took like 5 minutes to boot!

After that I issued the command sudo grub-install /dev/sda.

I rebooted and now I had ubuntu's grub (the result I wanted to achieve), but, the problem was not fixed!

How can I fix this?

  • Looks like you're not the only one. Someone over at AskUbuntu had the same problem — maybe the answer there will help? – Fox Mar 5 '17 at 19:40
  • (A summary of the AskUbuntu page:) At least at some point in the past, Kali would change the UUID of the swap partition. Then Ubuntu would have errors, slowing down the boot. Check your fstab entries in both Ubuntu and Kali, and make sure they all point to valid partitions – Fox Mar 5 '17 at 19:44
  • @Fox damn, hope I can fix this without reinstalling. – Tommaso Thea Cioni Mar 5 '17 at 19:50
  • @Fox Through the installation of kali it told me it would format sda6 (my ubuntu swap partition) as swap, but I thought it was ok and that ubuntu would keep using that partition along with kali. – Tommaso Thea Cioni Mar 5 '17 at 19:52
  • @Fox Hey look can you be a bit more specific on fstab? I don't know what that means. – Tommaso Thea Cioni Mar 5 '17 at 19:52
0

Here's how I fixed this on my laptop.

Background: Brand new Asus Gaming laptop with i7 and 16GB RAM. Has a Samsung 960 NVME. Would boot Win10 to the desktop in 4 seconds from power on.

Installed Ubuntu Gnome 16.04.3 and was taking over a minute to boot with Grub timeout set to 1 second and Windows as primary (used grub customizer).

Tried turning off fast boot and turned off superfetch service.

How I fixed it: In the bios, the boot order had Ubuntu listed first, Windows second. I changed it to Windows first, that fixed it.

The side effect is now I have to hit ESC to bring up boot order if I want to boot Ubnuntu. I'll also have to use grub customizer again to set Ubuntu as primary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.