2

I setup 389 Directory Server on RHEL 6.5 OS and Setup worked beautifully , Then i created a user on 389-ds and connected a client to DS and using the user which i created on 389 Directory Server i'm able to login to client system.

When i try to login using the user which i created on 389 Directory Server im not able to login on inspection i found the user is not in /etc/passwd file .

2

The users on a LDAP or 389 directory server are not created in /etc/passwd but in a separate database backend.

If you also want to login with the LDAP/389 users on the DS itself you have to configure it as a client as well and configure your name lookups for users and groups in /etc/nsswitch and PAM modules to make use of your LDAP/389 directory server.

  • Ok, i tried to install 389 DS as a client also but couldn't find any option to install as client, So i tried to authenticate using authconfig-tui and later ran command "getent passwd" shows nothing, but "getent passwd mrldap" shows mrldap user but still couldn't login. Any suggestions ... – OmiPenguin Mar 6 '17 at 6:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.