43

I am using gtk-recordmydesktop to record the video output to my desktop. However, the videos have no sound. All the tutorials I found regarding this involved getting sound recorded from a microphone, while I am interested in getting the sound output recorded. How can I do this? The official FAQ says "The solution is in your mixer's settings. Keep playing with it ;)." which doesn't clarify anything.

How can I get the sound output recorded, while being able to hear it myself also?

1
45
+50

I managed to get it going with the steps on the Ubuntu Forums, for clarity here is what I did:

  1. sudo apt-get install gtk-recordmydesktop pavucontrol
  2. Opened the Pulse Audio Volume Control dialog: Applications > Sound & Video > PulseAudio Volume Control
  3. Opened gtk-recordmydesktop
  4. In gtk-rmd advanced preferences, "Sound" tab, set "Device" to pulse
  5. In gtk-rmd start a recording
  6. In Volume Control goto the Recording tab and change the recordmydesktop entry to 'Monitor of '

This is what seems to have worked for me.

7
  • Note: with the 'Monitor of' setting, it should be a carbon copy and you will be able to hear the same audio through headphones etc.
    – N J
    Nov 12 '10 at 11:09
  • 6
    This worked. FWIW, I had to change the Sound > Device option from DEFAULT to pulse in gtk-recordmydesktop, though that could just be the way Arch was set up beforehand to have a different default.
    – Macha
    Nov 13 '10 at 14:18
  • @Macha on the command line, this corresponds to passing "--device pulse"
    – user3356
    Mar 20 '12 at 21:03
  • Thanks for pointing out pavucontrol; the recording was initially muted for some reason. Another FWIW, I had to change the profile (configuration tab of pavucontrol) from Duplex to Output, and that finally did it.
    – falstro
    Apr 28 '14 at 8:08
  • 3
    is there any way to get both the input mic AND the monitor of the audio output? Aug 15 '14 at 20:31
15

All I had to do was change DEFAULT to pulse in by: Advanced button > Sound tab > Device:.

2
  • I confirm that does the trick!
    – Capy
    May 27 '13 at 14:46
  • This isn't all I had to do (I also had to do the pavucontrol thing from the other answer), but it was required Aug 10 '16 at 6:41
5

If you use Pulseaudio, there is a howto in the Ubuntu Wiki. It basically boils down to using the pulse audio mixer, to re-route the sound from its source to audacity where it is saved instead of the default output (which would be you speakers).

3
  • 1
    Sadly, this sounds like it means I can't hear the sound myself, which isn't good enough.
    – Macha
    Oct 25 '10 at 17:55
  • 2
    @Macha: In principle, I think Pulseaudio is capable of replicating output on several ports. Did you find no way of doing this? Otherwise, a workaround that may or may not be acceptable is to play the sound file as it gets recorded (this may introduce unacceptable latency, and you'll probably have to record to a raw (uncompressed) format). Nov 8 '10 at 21:24
  • 1
    @Gilles: Ok, thanks. My bad. The tutorial actually said that, but the way the answer was worded implied otherwise. There is one last problem: This way requires me to manually sync the sound as gtk-recordmydesktop and audacity are started seperately.
    – Macha
    Nov 9 '10 at 19:20
1

I had to use these settings in pavucontrol:

Configuration > Built-in Audio > Profile > Digital Stereo (HDMI) Output + Analog Stereo Input

Then it recorded the sound that was playing

1

The sound is not recording due to low input level. You can fix this from here:

  • Go to sound application of settings. Then in there you will see input option adjacent to output.
  • You have just to increase the level of input from zero to approx 35-40%. This is the best level as experienced by me.
  • Now again go to recordMyDesktop app and start your recording.

It will work fine(at least it worked for me).

1

Changing my sound card device to "pulse" did not work. When I changed it to "default", it worked.

Debian, kernel 4.9.0-8-amd64
from lspci -v:
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)         Subsystem: Lenovo Broadwell-U Audio Controller
    Flags: bus master, fast devsel, latency 0, IRQ 48
    Memory at e1230000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
1
  • Apparently it's case sensitive... DEFAULT did not work for me but default did (while on another system, it needed to be pulse). Would be nice to know where to look for the correct device name. May 21 '20 at 2:55
0

This is an old question, but here it is for Mint 17.2:

  1. Open "Sound Preferences" -> "Input"
  2. Choose "Monitor of $YOUR_USUAL_OUTPUT_DEVICE"
  3. Record normally in gtk-rmd

This way you can avoid having the input switch recorded in the video.

Just remember to switch it back when you're done!

1
  • This no longer works for Linux Mint. Pulse audio mixer is necessary to make it work. Sep 19 '16 at 15:34
0

This setting works for me. Choose Monitors in the Show: in Input Devices

This setting works for me. Choose Monitors in the Show: in Input Devices

0

Vokoscreen workaround

This is the first thing I got working on Ubutu 20.04:

sudo apt install vokoscreen
vokoscreen

Then go to the audio settings and enable all pulse devices:

enter image description here

After that it just worked, captured both computer output and my voice on the microphone.

Kazam workaround

Kazam has a "Sound from speakers" checkbox that just worked on Ubuntu 20.04:

sudo apt install kazam
kazam

enter image description here

Unfortunately the video recording was bugged on Ubuntu 20.04: https://github.com/hzbd/kazam/issues/9

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.