I am using gtk-recordmydesktop to record the video output to my desktop. However, the videos have no sound. All the tutorials I found regarding this involved getting sound recorded from a microphone, while I am interested in getting the sound output recorded. How can I do this? The official FAQ says "The solution is in your mixer's settings. Keep playing with it ;)." which doesn't clarify anything.

How can I get the sound output recorded, while being able to hear it myself also?

  • 1
    I have created a video tutorial that covers the steps on 2014 Debian Linux. Commented Dec 15, 2014 at 10:52

10 Answers 10


I managed to get it going with the steps on the Ubuntu Forums, for clarity here is what I did:

  1. sudo apt-get install gtk-recordmydesktop pavucontrol
  2. Opened the Pulse Audio Volume Control dialog: Applications > Sound & Video > PulseAudio Volume Control
  3. Opened gtk-recordmydesktop
  4. In gtk-rmd advanced preferences, "Sound" tab, set "Device" to pulse
  5. In gtk-rmd start a recording
  6. In Volume Control goto the Recording tab and change the recordmydesktop entry to 'Monitor of '

This is what seems to have worked for me.

  • Note: with the 'Monitor of' setting, it should be a carbon copy and you will be able to hear the same audio through headphones etc.
    – N J
    Commented Nov 12, 2010 at 11:09
  • 6
    This worked. FWIW, I had to change the Sound > Device option from DEFAULT to pulse in gtk-recordmydesktop, though that could just be the way Arch was set up beforehand to have a different default.
    – Macha
    Commented Nov 13, 2010 at 14:18
  • @Macha on the command line, this corresponds to passing "--device pulse"
    – user3356
    Commented Mar 20, 2012 at 21:03
  • Thanks for pointing out pavucontrol; the recording was initially muted for some reason. Another FWIW, I had to change the profile (configuration tab of pavucontrol) from Duplex to Output, and that finally did it.
    – falstro
    Commented Apr 28, 2014 at 8:08
  • 3
    is there any way to get both the input mic AND the monitor of the audio output? Commented Aug 15, 2014 at 20:31

All I had to do was change DEFAULT to pulse in by: Advanced button > Sound tab > Device:.

  • I confirm that does the trick!
    – Capy
    Commented May 27, 2013 at 14:46
  • This isn't all I had to do (I also had to do the pavucontrol thing from the other answer), but it was required Commented Aug 10, 2016 at 6:41

If you use Pulseaudio, there is a howto in the Ubuntu Wiki. It basically boils down to using the pulse audio mixer, to re-route the sound from its source to audacity where it is saved instead of the default output (which would be you speakers).

  • 1
    Sadly, this sounds like it means I can't hear the sound myself, which isn't good enough.
    – Macha
    Commented Oct 25, 2010 at 17:55
  • 2
    @Macha: In principle, I think Pulseaudio is capable of replicating output on several ports. Did you find no way of doing this? Otherwise, a workaround that may or may not be acceptable is to play the sound file as it gets recorded (this may introduce unacceptable latency, and you'll probably have to record to a raw (uncompressed) format). Commented Nov 8, 2010 at 21:24
  • 1
    @Gilles: Ok, thanks. My bad. The tutorial actually said that, but the way the answer was worded implied otherwise. There is one last problem: This way requires me to manually sync the sound as gtk-recordmydesktop and audacity are started seperately.
    – Macha
    Commented Nov 9, 2010 at 19:20

I had to use these settings in pavucontrol:

Configuration > Built-in Audio > Profile > Digital Stereo (HDMI) Output + Analog Stereo Input

Then it recorded the sound that was playing


The sound is not recording due to low input level. You can fix this from here:

  • Go to sound application of settings. Then in there you will see input option adjacent to output.
  • You have just to increase the level of input from zero to approx 35-40%. This is the best level as experienced by me.
  • Now again go to recordMyDesktop app and start your recording.

It will work fine(at least it worked for me).


Changing my sound card device to "pulse" did not work. When I changed it to "default", it worked.

Debian, kernel 4.9.0-8-amd64
from lspci -v:
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)         Subsystem: Lenovo Broadwell-U Audio Controller
    Flags: bus master, fast devsel, latency 0, IRQ 48
    Memory at e1230000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
  • Apparently it's case sensitive... DEFAULT did not work for me but default did (while on another system, it needed to be pulse). Would be nice to know where to look for the correct device name. Commented May 21, 2020 at 2:55

Vokoscreen workaround

This is the first thing I got working on Ubutu 20.04:

sudo apt install vokoscreen

Then go to the audio settings and enable all pulse devices:

enter image description here

After that it just worked, captured both computer output and my voice on the microphone.

Kazam workaround

Kazam has a "Sound from speakers" checkbox that just worked on Ubuntu 20.04:

sudo apt install kazam

enter image description here

Unfortunately the video recording was bugged on Ubuntu 20.04: https://github.com/hzbd/kazam/issues/9


This is an old question, but here it is for Mint 17.2:

  1. Open "Sound Preferences" -> "Input"
  2. Choose "Monitor of $YOUR_USUAL_OUTPUT_DEVICE"
  3. Record normally in gtk-rmd

This way you can avoid having the input switch recorded in the video.

Just remember to switch it back when you're done!

  • This no longer works for Linux Mint. Pulse audio mixer is necessary to make it work. Commented Sep 19, 2016 at 15:34

This setting works for me. Choose Monitors in the Show: in Input Devices

This setting works for me. Choose Monitors in the Show: in Input Devices


I couldn't get gtk-recordmydesktop or kazam to work, no sound... in the finish I use OBS Studio and it works perfectly

I thought this was self-explanatory as an answer, gtk-recordmydesktop and kazam are broken, because why would OBS Studio work when they do not. How is OBS different.

For gtk-recordmydesktop I have tried installing qjackctl and pulse-module-jack to enable the jack feature in the program and that results in an immediate status 256 error. Moving on I tried changing default to hw:1,0 and got audio hiss in the background of my recorded video but no actual sound I wanted to record. I wondered if my system had a problem with ogv so I converted the file to mp4 which is what OBS uses and the converted file still has no sound.

Using aplay -l I get a list of my audio device and seems to suggest I need to use hw:2,0 but that doesn't seem to work either.

Next thing I am trying is to move my audio output to my microphone input with default, hw:1,0 and pulse using the gst-launch-1.0 pulsesrc ! pulsesink command after installing gstreamer-tools, this doesn't work

Tried fiddling with gnome-alsamixer, projectm-jack no sound in gtk-recordmydesktop, I have now installed pavucontrol and following this I can record audio in audacity but am yet to figure out how to get it to work in gtk-recordmydesktp, I got it to work finally by using a setting in pavucontrol here is an image of the setting, now it works, apparently I have to do it at least once in each of my recording programs for it to work. gtk-recordmydesktop in its advanced sound tab is now set to DEFAULT

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .