1

I run Samba on my Debian NAS and have two problems. Samba run fine and I can upload and download files without any problems.

The first problem:

I have a folder /mnt/disk/public/JDownloads/ in that folder are files downloaded by JDownloader. But some of them are not visable when I watch in that folder from Windows or any Samba client!

Jdownloader downloaded the files in that folder by user jdownloader and group jdownloader.

Why I can not see all files?

And the second problem is:

In that folder also are some Directorys created by JDownloader but I can not delete that folder from Windows explorer!

I have tried to solve the first problem by force samba connections to be root by (I think root can read and write all file no metter wich user):

force group = root
force user = root

And the second problem with:

delete readonly = yes

but no success. please help

Here is my conf for this share:

path = /mnt/disk/public
read only = no
writable = yes
browsable = yes
delete readonly = yes
valid users = root jdownloader
force group = root
force user = root

greetings

0

Linux users are stored in /etc/passwd, samba users are stored in /etc/samba/smbpasswd

It's not true that all linux users automatically, have access to samba You have to add samba users with the command smbpasswd.

Have you tried to add the jdownloader user to samba with

smbpasswd -a jdownloader

and from client-side to login as user jdownloader? (restart smb daemon, connection with new credentials)


As a quick & dirty solution you might use these global settings

force create mode = 777
force directory mode = 777
force security mode = 777
force directory security mode = 777

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.