4

After upgrading to Linux Mint 18, my wifi has randomly stopped working. When I turn the wifi off and back on repeatedly from the wifi applet (or put my laptop to sleep and back repeatedly), at some point the wifi no longer starts. The wifi applet displays one previous (no longer in range) network and never refreshes the list of networks.

In Linux Mint 17.3 the wifi faced a similar issue which could be fixed by running nmcli nm sleep false. In earlier releases the wifi worked 100% of the time.

The nmcli command no longer works in Mint 18, it just displays the error Error: Object 'nm' is unknown, try 'nmcli help'. I haven't found any other way to get the wifi back working other than rebooting my laptop, which is very frustrating.

My question is either:

  1. How can I resolve the issue so it no longer happens?

or alternatively

  1. How can I restore my wifi without rebooting my laptop?

Here is a dump of dmesg and syslog for a case where I first rebooted my laptop and it automatically connected to a wifi network (0-15). I then turned off and on the wifi (82-83) and the wifi did not wake up. After a while I turned if off and on again (133). Please ask if you need additional output. My laptop is a ThinkPad T430s.

Relevant portion of lspci -knn:

00:19.0 Ethernet controller [0200]: Intel Corporation 82579LM Gigabit Network Connection [8086:1502] (rev 04)
        Subsystem: Lenovo 82579LM Gigabit Network Connection [17aa:21f3]
        Kernel driver in use: e1000e
        Kernel modules: e1000e
03:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] [8086:0085] (rev 34)
        Subsystem: Intel Corporation Centrino Advanced-N 6205 AGN [8086:1311]
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi
  • Please add the output of lspci -knn | grep Net -A2 to get some information about the wifi card then disable the IPV6 (edit your /etc/sysctl.conf ) wiki.debian.org/DebianIPv6#How_to_turn_off_IPv6 – GAD3R Mar 4 '17 at 22:21
  • Create a /etc/modprobe.d/iwlwifi.conf with the following content options iwlwifi bt_coex_active=0 swcrypto=1 11n_disable=8 then reboot your system – GAD3R Mar 8 '17 at 13:57
  • @GAD3R neither disabling IPV6 nor adding the line to iwlwifi.conf helped. – Sampo Mar 9 '17 at 6:06
  • It seems that bt_coex_active=0 AND disabling Bluetooth from the Bluetooth manager helps. Will test later today in a different wifi area still. – Sampo Mar 9 '17 at 6:25
  • bt_coex_active=0 11n_disable=8 swcrypto=1 and disabling Bluetooth seems to reduce the frequency, but not remove it completely. sudo service network-manager restart did fix the issue from a dysfunctional state though. – Sampo Mar 16 '17 at 7:51
2

I also use Linux Mint 18 (Sarah). About few months ago, this problem also start to happening to me (and it still problem no.1 with my laptop).

I tried to find solution on Linux Mint help chanel about 3 month ago. Guys told me that is probably some problem/bug with xfce indicator. So they advice to me to use these command to restart nm:

sudo service network-manager restart

which is actually works, but - not every time in my case. Sometimes I must log-out and log-in again (Ctrl + Alt + Backspace).

EDIT: Well, after a while I decide to edit this post. Reason - I found a way! Finally I don't need to logout anymore;

killall nm-applet; nohup nm-applet &
  • 2
    As a solution for preventing the problem from occurring has not been proposed, I'll accept this answer as a way of fixing it when it occurs. – Sampo Mar 30 '17 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.