0

i am currently trying to get gcalcli for conky to work. gcalcli and all dependencies stated in the readme installed.

running "gcalcli agenda" got me an error messages, stating that oauth2client 1.5.0 or higher was required. So I installed that. Now I am absolutly stuck at this error message when running "gcalcli agenda":

pkg_resources.ContextualVersionConflict: (oauth2client 1.4.12 >(/usr/lib/python2.7/site-packages/oauth2client-1.4.12-py2.7.egg), >Requirement.parse('oauth2client<5.0.0dev,>=1.5.0'), set(['google-api-python->client']))

Seems like there is a conflict between those versions. Gcalcli wants to use oauth2client 1.4.12. Deleting it causes an error afterwards. The Google API on the other side requires version 5.0.0 >= 1.5.0.

I have version 1.4.12 AND 1.5.2 installed. But somehow it doesn't like having both versions even though they are required...?

Any help would be highly appreciated. Thank you very much ! :) And have a great day.

(running on Chapeau 24 based on Fedora)

0

Solved. Seems like only gcalcli's latest version 4.0.0.a works. Using that and every required packages as stated in the readme gets it to work flawlessly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.