2

I installed Debian 9 stretch testing version. And I did the below:

# apt-get update
# apt-get install network-manager-gnome
# apt-get install firmware-iwlwifi

My network card is Intel Corporation Wireless 8260

# lspci | grep Wireless
04:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)

So I come to Linux Support for Intel wireless adapter to download the Wi-Fi driver.

Intel® Dual Band Wireless-AC 8260       4.1     iwlwifi-8000-ucode-25.30.13.0.tgz

And I put the Wi-Fi driver under /lib/firmware.

But when I click Wi-Fi in the notification area, "Select network", the Wi-Fi networks pops up, "No network" message is displayed. It seems that it cannot detect the Wi-Fi.

Does anybody know the reason?

  • Reloading the driver modprobe -r iwlwifi ; modprobe iwlwifi doesn't help? – GAD3R Mar 2 '17 at 19:04
  • Thanks GAD3R! # modprobe -r iwlwifi; modprobe: FATAL: Module iwlwifi is in use; # modprobe iwlwifi; no return message. But when I open "Select Networks", the wifi driver cannot detect the wifi SSID. – Janice Lu Mar 3 '17 at 23:11
  • 1
    To unload/reload iwlwifi, first modprobe -r iwlmvm || modprobe -r iwldvm. Or use lsmod|grep iwlwifi, it will tell you which one of the two sub-modules is loaded & using iwlwifi, so you can unload it first. – sourcejedi Mar 4 '17 at 11:01
  • Thanks sourcejedi. I had wifi icon on my top right corner of desktop. But when I clicking Select Network, it seems that the network card cannot find the surrounding wifi SSID. – Janice Lu Mar 5 '17 at 2:45
1

To install the wifi for the Intel Corporation Wireless 8260 , download the driver from here, extract it then copy it to your /lib/firmware:

wget https://wireless.wiki.kernel.org/_media/en/users/drivers/iwlwifi-8000-ucode-16.242414.0.tgz
tar xvf iwlwifi-8000-ucode-16.242414.0.tgz
cd iwlwifi-8000-ucode-16.242414.0
cp iwlwifi-8000-ucode* /lib/firmware
modprobe iwlwifi
  • Thanks GAD3R, I tried, but still cannot figure out. The wifi networks still cannot find the surrounding wifi SSID. I don't know why. Does it related to /etc/network/interfaces? I have the following interfaces: auto lo iface lo inet loopback. I also used iwconfig, it is as below: wlp4s0 IEEE 802.11 ESSID:off/any Mode: Managed Access Point: Not-Associated Tx-Power=0 dBm Retry short limit: 7 RTS thr: off Fragment thr: off Encryption key: off Power Management: on Enp0s31f6 no wireless extensions. lo no wireless extensions. – Janice Lu Mar 5 '17 at 2:38
  • GAD3R, it seems that I did not configure IP address manually. When I use "ip address show", it displays the following information: 3: wlp4s0: <BROADCAST, MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000 link/ether 1a:15:e3:83:e7:61 brd ff:ff:ff:ff:ff:ff – Janice Lu Mar 5 '17 at 3:01
  • Run ip link set wlp4s0 up then try to scan for the AP through iw dev wlp4s0 scan – GAD3R Mar 5 '17 at 10:09
  • GAD3R, I ran ip link set wlp4s0, it says RTNETLINK answers: Input/output error – Janice Lu Mar 5 '17 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.