I have Debian Jessie installed on my laptop. I can't get my WiFi to work. In Wicd Network Manager it says there are no available wireless networks.

Running lspci gives me:

Network controller: Intel Corporation Wireless 3160 (rev 83). 

I have tried everything I found on the internet such as editing /etc/network/interfaces, installing drivers, updating, installing other things, editing more .conf files, etc. I just can't connect to WiFi. Ethernet works but sometimes I will need to use WiFi. I have Debian Jessie installed on my laptop. I can't get my WiFi to work! Anyone have any ideas how to get my WiFi working?

  • apt-get install firmware-iwlwifi from the non-free repositories. – Rui F Ribeiro Mar 2 '17 at 13:28
  • @RuiFRibeiro I have done that. – cppxor2arr Mar 2 '17 at 13:39

According to the official website , the Intel® Dual Band Wireless-AC 3160 is supported by the kernel version 4.1 and higher.

to get the wifi install the latest kernel from backports

Edit your sources.list by adding the following line:

deb http://httpredir.debian.org/debian jessie-backports main contrib non-free

Update and search for available linux-image's :

apt update
apt-cache search linux-image

Install the latest, e,g:

apt install linux-image-4.9.0-0.bpo.1-amd64


apt install linux-image-4.9.0-0.bpo.1-amd64-unsigned

Reboot your system

Download the required driver:

wget https://wireless.wiki.kernel.org/_media/en/users/drivers/iwlwifi-3160-ucode-16.242414.0.tgz

Copy it to your /lib/firmware:

tar xvf iwlwifi-3160-ucode-16.242414.0.tgz
cd iwlwifi-3160-ucode-16.242414.0
cp iwlwifi-3160-ucode* /lib/firmware
modprobe iwlwifi

To solve the unmet dependencies error , run:

apt-get -t jessie-backports install linux-base

As motioned @ Rui F Ribeiro, Installing the next stable release (debian 9) should be the best solution to deal with intel driver witch depends on the most recent kernel release on debian.

  • 1
    I have not tried this. I will tell you if it works. – cppxor2arr Mar 2 '17 at 13:39
  • 2
    +1 for 4.1/backports mentioning. I would also add that if you are installing from scratch, better go directly to Stretch/Debian 9 as it will be out in a couple of days. – Rui F Ribeiro Mar 2 '17 at 13:41
  • 1
    When I try to run apt install linux-image-4.9.0-0.bpo.1-amd64 I get this: The following packages have unmet dependencies: linux-image-4.9.0-0.bpo.1-amd64 : Depends: linux-base (>= 4.3~) but 3.5 is to be installed E: Unable to correct problems, you have held broken packages. – cppxor2arr Mar 2 '17 at 13:46
  • @6EQUJ5 Right! see my edit please – GAD3R Mar 2 '17 at 13:54
  • 1
    Hmmmm apt install linux-image... should be made after installing iwlwifi. Otherwise when rebooting, it wont go up, as it did not make into initrd. I would sugest dpkg-reconfigure linux-image-4.9.0-0.bpo.1-amd64 to correct this. – Rui F Ribeiro Mar 2 '17 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.