3

I am trying to install steam on my BunsenLab laptop (Debian 8/Jessie).

After enabling multi arch and apt-get steam:i386, I first encountered a missing library error, which I fixed by also installing libglib2.0-0:i386, libgtk2.0-0:i386 and pulseaudio:i386, which were containing the right .so files.

However, steam still doesn't work, it start, print the "Downloading update" window at ~40% downloading, and silently crash. Running it in native mode (STEAM_RUNTIME=0 steam) make a new error appear:

Error: Could not load module 'vgui2_s.so'.

However, I can't seems to find the package containing this library.

How can I debug the problem? Or find the right package for that library?

Note: I had to use the jessie-backport kernel to support my Intel HD Graphics chipset.

0

Don't know which one fixed it, but for another app (GOG version of Hacknet), I had to install the jessie-backports version of thoses packages:

  • libegl1-mesa
  • libegl1-mesa-drivers
  • libgl1-mesa-dri
  • libgl1-mesa-glx
  • libglapi-mesa
  • libgles1-mesa
  • libgles2-mesa
  • libglu1-mesa
  • libopenvg1-mesa
  • libtxc-dxtn-s2tc0
  • libwayland-egl1-mesa
  • mesa-utils
  • mesa-utils-extra
  • libva-drm1

Now Steam start and work. Games have other problems, but steam itself run without problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.