9

I've noticed that the automatic time zone detection functionality of my GNOME 3 (Arch Linux) is not working correctly. My actual time zone is PST (UTC-08), but if I toggle on the "Automatic Time Zone" option in "All Settings -> Date & Time", it would detect me to be in EST (UTC-05).

Kernel: 4.9.11-1-ARCH

GNOME: 3.22.3-1

Output of timedatectl:

      Local time: Wed 2017-03-01 05:36:18 EST
  Universal time: Wed 2017-03-01 10:36:18 UTC
        RTC time: Wed 2017-03-01 10:36:18
       Time zone: America/New_York (EST, -0500)
 Network time on: yes
NTP synchronized: yes
 RTC in local TZ: no

Output of sudo hwclock --show: 2017-03-01 05:37:38.295861-0500 (Which is the current EST time)

Output of date: Wed Mar 1 05:39:07 EST 2017

I suspected it was something wrong with my IP address, but all online IP location finder websites I've tried tell me I'm in San Francisco (which is correct). Also, I'm running dual systems (Windows 10 & Arch), and one OS writing the hardware clock always results in the other OS having an incorrect time on the next boot; I just ignore it and let the OSes' internet time services correct it. Wrong time zone detection only began today.

I'm not sure how to approach this issue. Can anyone shed some light on what might be the cause?

1
  • 3
    timedatectl set-local-rtc 1 should let Arch and Windows agree about the clock, though that doesn't solve your time zone issue
    – Fox
    Mar 1, 2017 at 12:52

1 Answer 1

0

NOTE This is ( as Roaima stated a comment, cited below ) not a full solution to the problem

That's just putting sticky plaster over the problem. There shouldn't really be a problem running both Windows and Linux-based systems with the hardware clock set to UTC –  roaima

probably a bit late, but have you tried to setting ntp?

Although; use with caution, it may be some security concerns involving ntp, I'm just providing this. in hope it will be useful.

timedatectl set-ntp true

Network Time Protocol Security concerns -en.wikipedia.org

You could also try:

gsettings set org.gnome.desktop.datetime automatic-timezone true

Note: If something downright wrong with any of my posts is spotted; Please point that out right away! //thanks! Appreciate it!

I've had this problem quite a lot for the time being, and I have solved it (probably isn't the most optimal way) by:

timedatectl set-time <the actual **correct time**>

timedatectl set-timezone <Your timezone>

and, then - after that you try:

timedatectl set-ntp true

Hope this helps someone in the future.



footnotes

the synonyms of the word full can be complete , satisfactory or adequate (...)

2
  • 2
    That's just putting sticky plaster over the problem. There shouldn't really be a problem running both Windows and Linux-based systems with the hardware clock set to UTC Jan 5, 2023 at 21:54
  • +1 @roaima Yes thank you for the comment(really) -- It really is just covering the problem/ or being a shortcut/ (I Will add that to the title of my answer, again thanks for pointing it out)! Jan 6, 2023 at 10:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .