1

I follow the document to install gitlab from source in Fedora 25. All of them seems correctly.

But if I run sudo -u git -H bundle exec rake gitlab:check RAILS_ENV=production, it will return this.

check GitLab API access: FAILED. code: 403
gitlab-shell self-check failed
  Try fixing it:
  Make sure GitLab is running;
  Check the gitlab-shell configuration file:
  sudo -u git -H editor /home/git/gitlab-shell/config.yml
  Please fix the error above and rerun the checks.

And the site is 403. see url

I have other site on the server with nginx and I use nginx with apache(port 8000) too. The other site can work correctly. see url

I have no idea to deal with it. I have tried to change premission with gitlab files into 775, but there is nothing changed.

I think the redis setting is true, because there is no error or warning for redis during I install gitlab.

The gitlib-shell/config.yml is here:

---
user: git
gitlab_url: https://git.vonfry.name
http_settings:
  self_signed_cert: false
  ca_file: "/letsencrypt/path/fullchain.pem"
auth_file: "/home/git/.ssh/authorized_keys"
redis:
  bin: "/bin/redis-cli"
  namespace: resque:gitlab
  host: localhost
  port: 6379
log_level: INFO
audit_usernames: false

The log file /var/log/nginx/gitlab_error.log

2017/02/28 14:43:27 [crit] 3189#0: *1 connect() to unix:/home/git/gitlab/tmp/sockets/gitlab-workhorse.socket failed (13: Permission denied) while connecting to upstream, client: 117.136.45.138, server: git.vonfry.name, request: "GET / HTTP/2.0", upstream: "http://unix:/home/git/gitlab/tmp/sockets/gitlab-workhorse.socket:/", host: "git.vonfry.name"
2017/02/28 14:43:27 [error] 3189#0: *1 open() "/home/git/gitlab/public/502.html" failed (13: Permission denied), client: 117.136.45.138, server: git.vonfry.name, request: "GET / HTTP/2.0", upstream: "http://unix:/home/git/gitlab/tmp/sockets/gitlab-workhorse.socket/", host: "git.vonfry.name"

1 Answer 1

0

I have find the reason.

For ubuntu or debine, a default user dir is 755. But it is 700 in fedora. I must set it into 755.

And the website can be viewed, but there are other problems that I need to fixed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .