2

I got nvidia 970 gtx made by evga in my desktop PC. I was using Fedora 25 for almost a month without any problems. I had drivers installed following instruction from rpm fusion howto.

dnf install xorg-x11-drv-nvidia akmod-nvidia "kernel-devel-uname-r == $(uname -r)"
dnf update -y

But live cannot be so simple! Yesterday I made a system update and turned off the machine. Today when it booted I saw a low-resolution mode, completely without nvidia graphic support. I chose other kernels from boot menu: the same.

I tried reinstalling nvidia drivers as in above posted howto also without result. Then I removed nvidia driver completely with

dnf remove xorg-x11-drv-nvidia\*

and did reboot. Now I ended with my desktop in a state that it doesn'n boot at all. After choosing the kernel in grub monitor goes blank in a moment and I cannot even go to terminal with ctrl+alt+F2.

In grub menu I tried rescue option, which leads me to kind of limited console, but I cannot install driver from there due to lack of internet connection in that mode.

I was reading some old thread which explained how to enter text mode, but it was in pre systemd era.

So... The question: how can I boot in this situation into text mode with internet support on Fedora 25 and systemd to be able to install drivers? Or is there any other easy way to fix it?

migrated from stackoverflow.com Feb 27 '17 at 20:44

This question came from our site for professional and enthusiast programmers.

1

I found out that solution was to edit boot option by clicking e and add nomodeset at the end of line starting with linuxefi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy