0

I am trying to change my MAC address via macchanger in linux mint 18. I use :

ifconfig wlp3s0 down     //must use, to avoid error "interface up"
macchanger -rb wlp3s0
ifconfig wlp3s0 up

The MAC address change successfully, but I have no internet after changing it, if I choose to connect to the same network from the panel (reconnect to the network), it reconnect and I have the internet back, but the MAC return to the default address. anyone faced this problem or know a fix ?

  • Why exactly do you need a MAC address change? – schaiba Feb 27 '17 at 12:53
  • 1
    @schaiba To get around limited-time free wifi; to protect your identity when using public wifi; to connect to a network with a mac address whitelist etc – user13757 Feb 27 '17 at 13:04
1

Mint overwrites the config in a few seconds. The solution is on a higher level.

  1. Right click on top of the "Network Connections" icon on the right bottom side of your screen and
  2. Go to "Edit connections..." option.
  3. Select your current Wi-Fi connection and
  4. Click on the Edit button.

    A small screen will appear with several Wi-Fi options.

  5. Find the option "Cloned MAC Address:".

  6. Fill in the blank with the MAC address you would like the interface to use.
  7. Save the change.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.