When using top, it shows me that cifsd has used lots of CPU time but in htop the process does not show up at all. I have tried enabling threads (with H) in htop, to no avail. It also does not show up in pstree, even when using parameters that might show me more info (-apcls).

I can find its process id in /proc so it exists.

In ps aux it shows up but in square brackets: [cifsd] is the value of the last column (titled COMMAND).

What kind of a process is this? From the CPU time over uptime, it seems to use 7.8% CPU on average (and it's pretty constant, when looking at top), so it's definitely a process of interest, but htop hides it.

  • 1
    Is it a kernel module? I suspect it must be something around that... Feb 27, 2017 at 11:19
  • 3
    Looks like a kernel thread, which is by default hidden in htop. So, update your configuration F2 -> Display Options -> Remove "x" at "Hide kernel threads".
    – Thomas
    Feb 27, 2017 at 11:23
  • @Thomas Ah, I did not know what square brackets indicated nor that htop hides those by default. Thanks! You should have posted as answer by the way, being earlier than ctx.
    – Luc
    Feb 27, 2017 at 14:08

1 Answer 1


Go to setup and change your 'Display' options:

F2 > Display options

Do not hide kernel threads and show custom thread names:

[ ] Hide kernel threads
[x] Show custom thread names



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.