1

Might be duplicate of this.

Every now and then my wifi stops working after I wake my laptop from suspend / hibernation or when reconnecting / changing between hotspots. I use normally networkmanager for managing my connections and sometimes when my wifi stops connecting, disabling networkmanager and changing to netctl helps. Usually just rebooting is the fastest solution.

Device and driver

Lenovo Thinkpad x230

03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)
    Subsystem: Intel Corporation Centrino Advanced-N 6205 AGN
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi

iwlwifi 0000:03:00.0: loaded firmware version 18.168.6.1 op_mode iwldvm

Logs

(tested with networkmanager and netctl)

https://bpaste.net/show/dfcb23dea3de

NETCTL
======

-- Unit netctl@wlp3s0\x2dJoutonetti.service has begun starting up.
helmi 27 00:03:24 kampela network[3712]: Starting network profile 'wlp3s0-Joutonetti'...
helmi 27 00:03:24 kampela kernel: iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
helmi 27 00:03:24 kampela kernel: iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
helmi 27 00:03:24 kampela kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
helmi 27 00:03:25 kampela kernel: iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
helmi 27 00:03:25 kampela kernel: iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
helmi 27 00:03:25 kampela kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
helmi 27 00:03:25 kampela kernel: IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
helmi 27 00:03:28 kampela kernel: wlp3s0: authenticate with 10:6f:3f:38:cb:e0
helmi 27 00:03:28 kampela kernel: wlp3s0: send auth to 10:6f:3f:38:cb:e0 (try 1/3)
helmi 27 00:03:29 kampela kernel: wlp3s0: send auth to 10:6f:3f:38:cb:e0 (try 2/3)
helmi 27 00:03:30 kampela kernel: wlp3s0: send auth to 10:6f:3f:38:cb:e0 (try 3/3)
helmi 27 00:03:31 kampela kernel: wlp3s0: authentication with 10:6f:3f:38:cb:e0 timed out
helmi 27 00:03:34 kampela kernel: wlp3s0: authenticate with 10:6f:3f:38:cb:e0
helmi 27 00:03:34 kampela kernel: wlp3s0: send auth to 10:6f:3f:38:cb:e0 (try 1/3)
helmi 27 00:03:35 kampela kernel: wlp3s0: send auth to 10:6f:3f:38:cb:e0 (try 2/3)
helmi 27 00:03:36 kampela kernel: wlp3s0: send auth to 10:6f:3f:38:cb:e0 (try 3/3)
helmi 27 00:03:37 kampela kernel: wlp3s0: authentication with 10:6f:3f:38:cb:e0 timed out
helmi 27 00:03:41 kampela network[3712]: WPA association/authentication failed for interface 'wlp3s0'
helmi 27 00:03:41 kampela network[3712]: Failed to bring the network up for profile 'wlp3s0-Joutonetti'
helmi 27 00:03:41 kampela systemd[1]: netctl@wlp3s0\x2dJoutonetti.service: Main process exited, code=exited, status=1/FAILURE
helmi 27 00:03:41 kampela systemd[1]: Failed to start Networking for netctl profile wlp3s0-Joutonetti.
-- Subject: Unit netctl@wlp3s0\x2dJoutonetti.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit netctl@wlp3s0\x2dJoutonetti.service has failed.
-- 
-- The result is failed.
helmi 27 00:03:41 kampela systemd[1]: netctl@wlp3s0\x2dJoutonetti.service: Unit entered failed state.
helmi 27 00:03:41 kampela systemd[1]: netctl@wlp3s0\x2dJoutonetti.service: Failed with result 'exit-code'.
helmi 27 00:03:41 kampela sudo[3597]: pam_unix(sudo:session): session closed for user root



NETWORKMANAGER
==============

helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.1319] device (wlp3s0): Activation: starting connection 'Auto Joutonetti' (3580733a-1f62-45e8-96cb-3e20d25d6f68)
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.1327] audit: op="connection-activate" uuid="3580733a-1f62-45e8-96cb-3e20d25d6f68" name="Auto Joutonetti" pid=3011 uid=1000 result="success"
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.1333] device (wlp3s0): state change: disconnected -> prepare (reason 'none') [30 40 0]
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.1336] manager: NetworkManager state is now CONNECTING
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.1409] device (wlp3s0): set-hw-addr: set-cloned MAC address to 6C:88:14:16:16:3C (permanent)
helmi 26 23:58:13 kampela kernel: iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
helmi 26 23:58:13 kampela kernel: iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
helmi 26 23:58:13 kampela kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
helmi 26 23:58:13 kampela kernel: iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
helmi 26 23:58:13 kampela kernel: iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
helmi 26 23:58:13 kampela kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
helmi 26 23:58:13 kampela kernel: IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.5608] device (wlp3s0): supplicant interface state: disconnected -> disabled
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.5732] device (wlp3s0): supplicant interface state: disabled -> disconnected
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.5740] device (wlp3s0): state change: prepare -> config (reason 'none') [40 50 0]
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.5749] device (wlp3s0): Activation: (wifi) access point 'Auto Joutonetti' has security, but secrets are required.
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.5754] device (wlp3s0): state change: config -> need-auth (reason 'none') [50 60 0]
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.5921] device (wlp3s0): state change: need-auth -> prepare (reason 'none') [60 40 0]
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.5943] device (wlp3s0): state change: prepare -> config (reason 'none') [40 50 0]
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.5950] device (wlp3s0): Activation: (wifi) connection 'Auto Joutonetti' has security, and secrets exist.  No new secrets needed.
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.5954] Config: added 'ssid' value 'Joutonetti'
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.5962] Config: added 'scan_ssid' value '1'
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.5968] Config: added 'key_mgmt' value 'WPA-PSK'
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.5972] Config: added 'psk' value '<omitted>'
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.6068] sup-iface[0xd6b0c0,wlp3s0]: config: set interface ap_scan to 1
helmi 26 23:58:13 kampela NetworkManager[2508]: <info>  [1488146293.6291] device (wlp3s0): supplicant interface state: disconnected -> scanning
helmi 26 23:58:16 kampela wpa_supplicant[642]: wlp3s0: SME: Trying to authenticate with 10:6f:3f:38:cb:e0 (SSID='Joutonetti' freq=2437 MHz)
helmi 26 23:58:16 kampela kernel: wlp3s0: authenticate with 10:6f:3f:38:cb:e0
helmi 26 23:58:16 kampela kernel: wlp3s0: send auth to 10:6f:3f:38:cb:e0 (try 1/3)
helmi 26 23:58:16 kampela NetworkManager[2508]: <info>  [1488146296.7105] device (wlp3s0): supplicant interface state: scanning -> authenticating
helmi 26 23:58:17 kampela kernel: wlp3s0: send auth to 10:6f:3f:38:cb:e0 (try 2/3)
helmi 26 23:58:18 kampela kernel: wlp3s0: send auth to 10:6f:3f:38:cb:e0 (try 3/3)
helmi 26 23:58:19 kampela kernel: wlp3s0: authentication with 10:6f:3f:38:cb:e0 timed out
helmi 26 23:58:19 kampela wpa_supplicant[642]: wlp3s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Joutonetti" auth_failures=1 duration=10 reason=CONN_FAILED
helmi 26 23:58:19 kampela NetworkManager[2508]: <info>  [1488146299.5438] device (wlp3s0): supplicant interface state: authenticating -> disconnected
helmi 26 23:58:29 kampela NetworkManager[2508]: <info>  [1488146309.5515] device (wlp3s0): supplicant interface state: disconnected -> scanning
helmi 26 23:58:29 kampela wpa_supplicant[642]: wlp3s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="Joutonetti"
helmi 26 23:58:37 kampela wpa_supplicant[642]: wlp3s0: SME: Trying to authenticate with 10:6f:3f:38:cb:e0 (SSID='Joutonetti' freq=2437 MHz)
helmi 26 23:58:37 kampela kernel: wlp3s0: authenticate with 10:6f:3f:38:cb:e0
helmi 26 23:58:37 kampela kernel: wlp3s0: send auth to 10:6f:3f:38:cb:e0 (try 1/3)
helmi 26 23:58:37 kampela NetworkManager[2508]: <info>  [1488146317.7083] device (wlp3s0): supplicant interface state: scanning -> authenticating
helmi 26 23:58:38 kampela kernel: wlp3s0: send auth to 10:6f:3f:38:cb:e0 (try 2/3)
helmi 26 23:58:39 kampela NetworkManager[2508]: <warn>  [1488146319.1681] device (wlp3s0): Activation: (wifi) association took too long, failing activation
helmi 26 23:58:39 kampela NetworkManager[2508]: <info>  [1488146319.1682] device (wlp3s0): state change: config -> failed (reason 'ssid-not-found') [50 120 53]
helmi 26 23:58:39 kampela NetworkManager[2508]: <info>  [1488146319.1689] manager: NetworkManager state is now DISCONNECTED
helmi 26 23:58:39 kampela NetworkManager[2508]: <warn>  [1488146319.1700] device (wlp3s0): Activation: failed for connection 'Auto Joutonetti'
helmi 26 23:58:39 kampela NetworkManager[2508]: <info>  [1488146319.1712] device (wlp3s0): state change: failed -> disconnected (reason 'none') [120 30 0]
helmi 26 23:58:39 kampela wpa_supplicant[642]: wlp3s0: CTRL-EVENT-DISCONNECTED bssid=10:6f:3f:38:cb:e0 reason=3 locally_generated=1
helmi 26 23:58:39 kampela kernel: wlp3s0: aborting authentication with 10:6f:3f:38:cb:e0 by local choice (Reason: 3=DEAUTH_LEAVING)
helmi 26 23:58:39 kampela kernel: IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
helmi 26 23:58:39 kampela NetworkManager[2508]: <info>  [1488146319.1796] device (wlp3s0): set-hw-addr: set MAC address to AE:F2:B4:C5:71:FD (scanning)
helmi 26 23:58:39 kampela kernel: iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
helmi 26 23:58:39 kampela kernel: iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
helmi 26 23:58:39 kampela kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
helmi 26 23:58:39 kampela kernel: iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
helmi 26 23:58:39 kampela kernel: iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
helmi 26 23:58:39 kampela kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
helmi 26 23:58:39 kampela kernel: IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
helmi 26 23:58:39 kampela NetworkManager[2508]: <warn>  [1488146319.5657] sup-iface[0xd6b0c0,wlp3s0]: connection disconnected (reason -3)
helmi 26 23:58:39 kampela NetworkManager[2508]: <info>  [1488146319.5667] device (wlp3s0): supplicant interface state: authenticating -> disconnected
helmi 26 23:58:39 kampela NetworkManager[2508]: <info>  [1488146319.5885] device (wlp3s0): supplicant interface state: disconnected -> disabled
helmi 26 23:58:39 kampela NetworkManager[2508]: <info>  [1488146319.5949] device (wlp3s0): supplicant interface state: disabled -> disconnected
0

This sounds common, just restart the network-manager service using init or systemd whichever is applicable.

Typically:

sudo service network-manager restart
| improve this answer | |
  • Restarting networkmanager or changing to netctl won't help. Nor does taking interface down and up again. Reloading kernel modules iwlwifi and iwldvm seems to help, but I've had change to test that only once. – warbaque Feb 28 '17 at 22:09
  • @warbaque Hmm, always works for me. Although, I am using a different kernel module (rto8192ce & rtlwifi) so that may be related. – J.T. Mar 19 '17 at 3:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.