I am using latest ubuntu 16.04 LTS. For some days after installing system worked fine but after some days it start showing this error.

Welcome to emergency mode! After logging in, type "journalctl -xb" to view system logs, "systemctl reboot" to reboot, "systemctl default" or ^D to try again to boot into dafault mode. Press Enter for maintenance (or press control-D to continue):

But there is one way using which I can start system. On boot up I go to recovery menu then clean package and then resume the system. It works but , it is time consuming to do after every boot up. Suggest something simple and cleaner to resolve this problem.

Before going into emergency mode it gave message as : [12.320307] intel_soc_dts_thermal:request_threaded_irq ret -22

In case anyone interested in seeing log files : http://www.filehosting.org/file/details/644902/error_log.txt

  • you might be running out of disk space .. have you checked that aspect ? – amisax Feb 27 '17 at 7:23
  • @amisax no not really there is too much space remaining. By the way system has dual boot with windows 8 if this may help in any sort. – WeAreRight Feb 27 '17 at 7:26
  • We are not clairvoyant. We cannot suggest things without knowing why emergency mode is being triggered; and we have no access to that knowledge. You have a message in front of you telling you to look at the logs, which would provide that knowledge. You aren't showing the logs in this question, nor indicating that you have even looked at them to see what the fault is. – JdeBP Feb 27 '17 at 8:10
  • @JdeBP I have log file. It consist of 4000 lines what you want should i paste it here? – WeAreRight Feb 27 '17 at 9:00
  • before going into emergency mode it gave message as : [12.320307] intel_soc_dts_thermal:request_threaded_irq ret -22 – WeAreRight Feb 27 '17 at 9:02

The Emergency Mode sometime means that your file system may be corrupted. In such cases, you will be left out with a prompt to go nowhere.

All you have to do is perform a file system check using,

fsck.ext4 /dev/sda3

where sda3 can be your partition and if you are using ext3 file system, change the command as follows:

fsck.ext3 /dev/sda3

About the partition number, Linux shows you the partition before arriving at the prompt.

This should solve the problem.

  • 1
    Worked perfectly. Thank you "Panther Coder" that was great help. Looking for solution from many days. Upvoted and accepted as answer. – WeAreRight Feb 27 '17 at 10:19
  • Worked like a charm for me as well. Thanks a lot! – Honza Dejdar Aug 10 '17 at 17:15
  • Thanks man! It did worked !!! – Marcos Alex May 24 '19 at 0:39

From my experience, if you have created a new partition or edited existing one, you may get this error. I had the same error some time back. If you happened to be in the the Emergency Mode and see that it cannot load some of your drive. It means that some of your device id have been changed. So, you have to update the id accordingly in /etc/fstab file. Then do the following steps.

  1. Type your root password
  2. cat /etc/fstab
  3. blkid (show the device ids)
  4. Now check which which UUID in /etc/fstab does not apper in blkid output
  5. type 'nono /etc/fstab' and Comment out that line (Just put # infront of the line)
  6. type 'reboot' (Now your problem should be fixed and after logging in successfully, you can add the current UUID in /etc/fstab file )

As an example, this is my output of /etc/fstab file, in which I simply commented out the line ( UUID=C3D1-3CB7 /windows vfat utf8,umask=007,gid=46 0 1), because the UUID=C3D1-3CB7 has been changed.

enter image description here

  • 2
    I had the same issue because I had deleted and reinstalled the EFI partition and after following the steps of this answer I was able to boot normally into Ubuntu. – Vassilis Barzokas Nov 30 '19 at 19:15

In my case, the fsck didn't help. But the problem was that, as a part of experimenting, I had created a virtual partition of a ext3 over the ext4 filesystem and mounted it.

It worked fine. Later had edited the fstab to automount that during boot. After the reboot after many days, the system went into emergency mode.

Finally entered the maintenance mode and edited the fstab file and rebooted. The system came up. It's a conflict of filesystem for sure.


Encountered the same problem. Here's a solution that might work:

use Ubuntu Live USB to boot, and open terminal:

sudo fsck.ext4 /dev/sda3

addingsudo because it needs root permission.

(Replace ext4 with ext3 if applicable to you)

Cycle through the SDAs by changing the last number in the sda to see which file system has problems.

Ex: sda1, sda2, sda3, sda4, and so on

As I encountered, the problem might be with the 'home' directory.

Once you run the above command, you'll be prompted to fix the issue right inside the terminal itself.

Keep hitting y (for yes) until the end of the fix.

(or you can use -fy for automatically response yes to all.)

Navigate to the home folder of your sda using your files explorer.

(This will be mounted from the HDD since you are working with a Live USB)

Check inside 'home' if you can see all your files. If yes, then you're ready to reboot to your system (remove the Live USB).


enter image description here----Firts of all download Gparted live cd, burn it to cd/dvd or usb card,open terminal then using this command blkid or fdisk -l to know parts

fsck -с /dev/mapper/yourhostname--vg-var

if your /var wan't mount

or if your /home wan't mount use this command

fsck -с /dev/mapper/yourhostname--vg-home

etc. -----------kblprbl312-----------------------------

  • 4
    Do not paste images. Paste commands in Code block instead. – Yurij Goncharuk Apr 9 '18 at 9:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.