1

I'm on OpenSUSE Leap 42.2. Reading/writing data to a SD card is very slow. Therefore I decided to partition/format it to resolve the problem. I tried to partition with sudo gdisk /dev/sdb but it cannot finish the job and returns Error 6.

I tried to format the existing partition on SD card with sudo mkfs /dev/sdb1 but it cannot finish operation.

Also I tried to run sudo dd if=/dev/zero of=/dev/sdb but it runs into read/write errors.

I wonder if there is any other tool to partition/format/erase/whatever the SD card.

  • For future reference, you can use Yast -> System -> Partitioner to handle making partitions and formating disks. It helps to verify that you have the correct disk before doing anything to it. Especially as OpenSUSE Leap has been known to reassign the /dev/sd? names during boot process. For now, as @db48x says, sounds like the SD card is dead, or dying, and it's time to replace it. – Gypsy Spellweaver Feb 27 '17 at 6:07
  • @GypsySpellweaver Thanks for Yast -> System -> Partitioner, I'll give it a try. – user3405291 Feb 27 '17 at 6:13
1

If you're getting read or write errors, then changing your tools won't help; the disk is bad. If you're reading from a broken disk then a tool like ddrescue can help, but that's not going to help you format it. Get a new disk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.