1

System : Debian GNU/Linux 8 (jessie) 64-bit

uname -r : 4.9.0-0.bpo.1-amd64

Well I updated kernel to 4.9. And updated all my packages. But now I'm trying to install skype and gtk3 library, and I get dependencies problem. In order to install skype I do this:

sudo dpkg --add-architecture i386
sudo aptitude update
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

Well and I end up with

 skype:i386 : Depends: libqt4-dbus:i386 (>= 4:4.5.3) but it is not installed
              Depends: libqt4-network:i386 (>= 4:4.8.0) but it is not installed
              Depends: libqt4-xml:i386 (>= 4:4.5.3) but it is not installed
              Depends: libqtcore4:i386 (>= 4:4.7.0~beta1) but it is not installed
              Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not installed
              Depends: libqtwebkit4:i386 (>= 2.1.0~2011week13) but it is not installed
              Depends: libstdc++6:i386 (>= 4.2.1) but it is not installed
              Depends: libx11-6:i386 but it is not installed
              Depends: libxext6:i386 but it is not installed
              Depends: libxss1:i386 but it is not installed
              Depends: libxv1:i386 but it is not installed
              Depends: libssl1.0.0:i386 but it is not installed
              Depends: libpulse0:i386 but it is not installed
              Depends: libasound2-plugins:i386 but it is not installed
E: Unmet dependencies. Try using -f

if I try apt-get -f install it will suggest to delete skype and that it. I tried aptitude, but also without result. And yes I'm already did apt-get update && apt-get install.

When I'm trying to install libgtk3 I got:

libgtk-3-dev : Depends: libatk-bridge2.0-dev but it is not going to be installed

Aptitude got me that :

libdbus-1-dev : Depends: libdbus-1-3 (= 1.8.22-0+deb8u1) but 1.10.14-1 is installed.

Well I thought that since I have newest library, I can force to install it older version to fix the dependencies problem but I got that :

 sudo aptitude install libdbus-1-3=1.8.22-0
Unable to find a version "1.8.22-0" for the package "libdbus-1-3"

I don't know what to do, it's not allowing me to install older libraries, and don't work with new ones. I search a lot about it, but all the problems was solved with apt-get update and install. How I can install this package?

//-------------

sudo apt-cache policy

Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://httpredir.debian.org/debian/ testing/non-free Translation-en
 500 http://httpredir.debian.org/debian/ testing/main Translation-en
 500 http://httpredir.debian.org/debian/ testing/contrib Translation-en
-500 http://httpredir.debian.org/debian/ testing/non-free i386 Packages
     release o=Debian,a=testing,n=stretch,l=Debian,c=non-free
     origin httpredir.debian.org
-500 http://httpredir.debian.org/debian/ testing/contrib i386 Packages
     release o=Debian,a=testing,n=stretch,l=Debian,c=contrib
     origin httpredir.debian.org
-500 http://httpredir.debian.org/debian/ testing/main i386 Packages
     release o=Debian,a=testing,n=stretch,l=Debian,c=main
     origin httpredir.debian.org
-500 http://httpredir.debian.org/debian/ testing/non-free amd64 Packages
     release o=Debian,a=testing,n=stretch,l=Debian,c=non-free
     origin httpredir.debian.org
-500 http://httpredir.debian.org/debian/ testing/contrib amd64 Packages
     release o=Debian,a=testing,n=stretch,l=Debian,c=contrib
     origin httpredir.debian.org
-500 http://httpredir.debian.org/debian/ testing/main amd64 Packages
     release o=Debian,a=testing,n=stretch,l=Debian,c=main
     origin httpredir.debian.org
 500 http://http.debian.net/debian/ jessie-backports/main Translation-en
 100 http://http.debian.net/debian/ jessie-backports/main i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
     origin http.debian.net
 100 http://http.debian.net/debian/ jessie-backports/main amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
     origin http.debian.net
 500 http://ftp.us.debian.org/debian/ jessie-updates/non-free Translation-en
 500 http://ftp.us.debian.org/debian/ jessie-updates/main Translation-en
 500 http://ftp.us.debian.org/debian/ jessie-updates/contrib Translation-en
 500 http://ftp.us.debian.org/debian/ jessie-updates/non-free i386 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=non-free
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian/ jessie-updates/contrib i386 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=contrib
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian/ jessie-updates/main i386 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=main
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian/ jessie-updates/non-free amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=non-free
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian/ jessie-updates/contrib amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=contrib
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian/ jessie-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=main
     origin ftp.us.debian.org
 500 http://ftp.debian.org/debian/ jessie-backports/main Translation-en
 100 http://ftp.debian.org/debian/ jessie-backports/main i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
     origin ftp.debian.org
 100 http://ftp.debian.org/debian/ jessie-backports/main amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
     origin ftp.debian.org
 500 http://ftp.us.debian.org/debian/ jessie-proposed-updates/non-free Translation-en
 500 http://ftp.us.debian.org/debian/ jessie-proposed-updates/main Translation-en
 500 http://ftp.us.debian.org/debian/ jessie-proposed-updates/contrib Translation-en
 500 http://ftp.us.debian.org/debian/ jessie-proposed-updates/non-free i386 Packages
     release v=8-updates,o=Debian,a=proposed-updates,n=jessie-proposed-updates,l=Debian,c=non-free
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian/ jessie-proposed-updates/contrib i386 Packages
     release v=8-updates,o=Debian,a=proposed-updates,n=jessie-proposed-updates,l=Debian,c=contrib
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian/ jessie-proposed-updates/main i386 Packages
     release v=8-updates,o=Debian,a=proposed-updates,n=jessie-proposed-updates,l=Debian,c=main
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian/ jessie-proposed-updates/non-free amd64 Packages
     release v=8-updates,o=Debian,a=proposed-updates,n=jessie-proposed-updates,l=Debian,c=non-free
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian/ jessie-proposed-updates/contrib amd64 Packages
     release v=8-updates,o=Debian,a=proposed-updates,n=jessie-proposed-updates,l=Debian,c=contrib
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian/ jessie-proposed-updates/main amd64 Packages
     release v=8-updates,o=Debian,a=proposed-updates,n=jessie-proposed-updates,l=Debian,c=main
     origin ftp.us.debian.org
 500 http://security.debian.org/ jessie/updates/non-free Translation-en
 500 http://security.debian.org/ jessie/updates/main Translation-en
 500 http://security.debian.org/ jessie/updates/contrib Translation-en
 990 http://security.debian.org/ jessie/updates/non-free i386 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=non-free
     origin security.debian.org
 990 http://security.debian.org/ jessie/updates/contrib i386 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=contrib
     origin security.debian.org
 990 http://security.debian.org/ jessie/updates/main i386 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 990 http://security.debian.org/ jessie/updates/non-free amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=non-free
     origin security.debian.org
 990 http://security.debian.org/ jessie/updates/contrib amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=contrib
     origin security.debian.org
 990 http://security.debian.org/ jessie/updates/main amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 500 http://ftp.us.debian.org/debian/ jessie/non-free Translation-en
 500 http://ftp.us.debian.org/debian/ jessie/main Translation-en
 500 http://ftp.us.debian.org/debian/ jessie/contrib Translation-en
 990 http://ftp.us.debian.org/debian/ jessie/non-free i386 Packages
     release v=8.7,o=Debian,a=stable,n=jessie,l=Debian,c=non-free
     origin ftp.us.debian.org
 990 http://ftp.us.debian.org/debian/ jessie/contrib i386 Packages
     release v=8.7,o=Debian,a=stable,n=jessie,l=Debian,c=contrib
     origin ftp.us.debian.org
 990 http://ftp.us.debian.org/debian/ jessie/main i386 Packages
     release v=8.7,o=Debian,a=stable,n=jessie,l=Debian,c=main
     origin ftp.us.debian.org
 990 http://ftp.us.debian.org/debian/ jessie/non-free amd64 Packages
     release v=8.7,o=Debian,a=stable,n=jessie,l=Debian,c=non-free
     origin ftp.us.debian.org
 990 http://ftp.us.debian.org/debian/ jessie/contrib amd64 Packages
     release v=8.7,o=Debian,a=stable,n=jessie,l=Debian,c=contrib
     origin ftp.us.debian.org
 990 http://ftp.us.debian.org/debian/ jessie/main amd64 Packages
     release v=8.7,o=Debian,a=stable,n=jessie,l=Debian,c=main
     origin ftp.us.debian.org
Pinned packages:

My source list:

# 

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main

#deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main

deb http://ftp.us.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.us.debian.org/debian/ jessie main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

deb http://ftp.us.debian.org/debian/ jessie-proposed-updates main contrib non-free

deb http://ftp.debian.org/debian/ jessie-backports main

# jessie-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.us.debian.org/debian/ jessie-updates main contrib non-free

also It seam to me something wrong here :

dpkg -l  |awk '/^ii/ && $3 ~ /bpo[6-8]/ {print $2}'

libgl1-mesa-dri:amd64
libllvm3.8:amd64
linux-compiler-gcc-4.9-x86
linux-headers-4.9.0-0.bpo.1-686-pae
linux-headers-4.9.0-0.bpo.1-all
linux-headers-4.9.0-0.bpo.1-all-amd64
linux-headers-4.9.0-0.bpo.1-amd64
linux-headers-4.9.0-0.bpo.1-common
linux-headers-4.9.0-0.bpo.1-common-rt
linux-headers-4.9.0-0.bpo.1-rt-686-pae
linux-headers-4.9.0-0.bpo.1-rt-amd64
mesa-vulkan-drivers

//output of sudo apt-show-versions | grep testing Well not expected to see so many packages, I just need a newest intell driver in order to work with vulkan.

bash-completion:all/testing 1:2.1-4.3 uptodate
binutils:amd64/testing 2.27.90.20170124-2 uptodate
console-setup:all/testing *manually* upgradeable from 1.158 to 1.160
console-setup-linux:all/testing *manually* upgradeable from 1.158 to 1.160
dbus:amd64/testing *manually* upgradeable from 1.10.14-1 to 1.10.16-1
flashplugin-nonfree:amd64/testing 1:3.7 uptodate
ifupdown:amd64/testing 0.8.19 uptodate
init-system-helpers:all/testing 1.47 uptodate
kbd:amd64/testing 2.0.3-2 uptodate
keyboard-configuration:all/testing *manually* upgradeable from 1.158 to 1.160
keyutils:amd64/testing 1.5.9-9 uptodate
libapparmor1:amd64/testing 2.11.0-2 uptodate
libdbus-1-3:amd64/testing *manually* upgradeable from 1.10.14-1 to 1.10.16-1
libdrm-amdgpu1:amd64/testing 2.4.74-1 uptodate
libdrm-dev:amd64/testing 2.4.74-1 uptodate
libdrm-intel1:amd64/testing 2.4.74-1 uptodate
libdrm-nouveau2:amd64/testing 2.4.74-1 uptodate
libdrm-radeon1:amd64/testing 2.4.74-1 uptodate
libdrm2:amd64/testing 2.4.74-1 uptodate
libegl1-mesa-drivers:amd64/testing 13.0.4-1 uptodate
libfdisk1:amd64/testing 2.29.1-1 uptodate
libgcrypt20:amd64/testing 1.7.6-1 uptodate
libgl1-mesa-glx:amd64/testing 13.0.4-1 uptodate
libglapi-mesa:amd64/testing 13.0.4-1 uptodate
libgssapi-krb5-2:amd64/testing 1.15-1 uptodate
libinput-bin:amd64/testing 1.6.0-1 uptodate
libinput10:amd64/testing 1.6.0-1 uptodate
libip4tc0:amd64/testing 1.6.0+snapshot20161117-5 uptodate
libjim0.76:amd64/testing *manually* upgradeable from 0.76-2 to 0.76-2+b1
libk5crypto3:amd64/testing 1.15-1 uptodate
libkrb5-3:amd64/testing 1.15-1 uptodate
libkrb5support0:amd64/testing 1.15-1 uptodate
liblz4-1:amd64/testing *manually* upgradeable from 0.0~r131-2 to 0.0~r131-2+b1
libmount1:amd64/testing 2.29.1-1 uptodate
libncurses5:amd64/testing 6.0+20161126-1 uptodate
libncursesw5:amd64/testing 6.0+20161126-1 uptodate
libpam-systemd:amd64/testing *manually* upgradeable from 232-15 to 232-18
libseccomp2:amd64/testing 2.3.1-2.1 uptodate
libselinux1:amd64/testing 2.6-3 uptodate
libsmartcols1:amd64/testing 2.29.1-1 uptodate
libssl1.1:amd64/testing *manually* upgradeable from 1.1.0d-2 to 1.1.0e-1
libsystemd0:amd64/testing *manually* upgradeable from 232-15 to 232-18
libtinfo5:amd64/testing 6.0+20161126-1 uptodate
libudev1:amd64/testing *manually* upgradeable from 232-15 to 232-18
libvulkan1:amd64/testing 1.0.39.0+dfsg1-1 uptodate
libwacom-common:all/testing 0.22-1 uptodate
libwacom2:amd64/testing 0.22-1 uptodate
libxfont2:amd64/testing 1:2.0.1-3 uptodate
linux-base:all/testing 4.5 uptodate
linux-kbuild-4.9:amd64/testing 4.9.6-3 uptodate
linux-libc-dev:amd64/testing 4.9.6-3 uptodate
mount:amd64/testing 2.29.1-1 uptodate
rpcbind:amd64/testing 0.2.3-0.5 uptodate
systemd:amd64/testing *manually* upgradeable from 232-15 to 232-18
systemd-sysv:amd64/testing *manually* upgradeable from 232-15 to 232-18
sysvinit-utils:amd64/testing *manually* upgradeable from 2.88dsf-59.8 to 2.88dsf-59.9
udev:amd64/testing *manually* upgradeable from 232-15 to 232-18
usb-modeswitch:amd64/testing 2.5.0+repack0-1 uptodate
util-linux:amd64/testing 2.29.1-1 uptodate
xserver-common:all/testing 2:1.19.1-4 uptodate
xserver-xorg:amd64/testing 1:7.7+18 uptodate
xserver-xorg-core:amd64/testing 2:1.19.1-4 uptodate
xserver-xorg-input-all:amd64/testing 1:7.7+18 uptodate
xserver-xorg-input-evdev:amd64/testing 1:2.10.5-1 uptodate
xserver-xorg-input-libinput:amd64/testing 0.23.0-2 uptodate
xserver-xorg-input-mouse:amd64/testing 1:1.9.2-1+b1 uptodate
xserver-xorg-input-synaptics:amd64/testing 1.9.0-1+b1 uptodate
xserver-xorg-input-wacom:amd64/testing 0.34.0-1 uptodate
xserver-xorg-video-ati:amd64/testing 1:7.8.0-1+b1 uptodate
xserver-xorg-video-cirrus:amd64/testing 1:1.5.3-1+b2 uptodate
xserver-xorg-video-fbdev:amd64/testing 1:0.4.4-1+b5 uptodate
xserver-xorg-video-intel:amd64/testing 2:2.99.917+git20161206-1 uptodate
xserver-xorg-video-mach64:amd64/testing 6.9.5-1+b2 uptodate
xserver-xorg-video-mga:amd64/testing 1:1.6.5-1 uptodate
xserver-xorg-video-neomagic:amd64/testing 1:1.2.9-1+b2 uptodate
xserver-xorg-video-nouveau:amd64/testing 1:1.0.13-1+b1 uptodate
xserver-xorg-video-openchrome:amd64/testing 1:0.5.0-3 uptodate
xserver-xorg-video-qxl:amd64/testing 0.1.4+20161126git4d7160c-1 uptodate
xserver-xorg-video-r128:amd64/testing 6.10.2-1 uptodate
xserver-xorg-video-radeon:amd64/testing 1:7.8.0-1+b1 uptodate
xserver-xorg-video-savage:amd64/testing 1:2.3.9-1 uptodate
xserver-xorg-video-siliconmotion:amd64/testing 1:1.7.9-1 uptodate
xserver-xorg-video-sisusb:amd64/testing 1:0.9.7-1 uptodate
xserver-xorg-video-tdfx:amd64/testing 1:1.4.7-1 uptodate
xserver-xorg-video-trident:amd64/testing 1:1.3.8-1 uptodate
xserver-xorg-video-vesa:amd64/testing 1:2.3.4-1+b2 uptodate
xserver-xorg-video-vmware:amd64/testing 1:13.2.1-1+b1 uptodate
  • 1
    Include the output of apt-cache policy in your post (after running apt update). – jordanm Feb 26 '17 at 18:49
  • ok, added to the post – alex_mike Feb 26 '17 at 19:00
  • 2
    Looks like you have mixed testing and stable. If you have ran an apt-get upgrade since adding testing to your sources, you are no longer running stable (jessie). – jordanm Feb 26 '17 at 19:01
  • well, theoretically if I understand correctly kernel 4.9 - available only in testing repository, therefore I added testing repository, now when everything screw up I need to find a solution to a problem – alex_mike Feb 26 '17 at 19:11
  • 1
    No, newer kernels are also available in Jessie backports. You've got some weird pinning going on too, I think that's the main reason you can't install Skype's dependencies... – Stephen Kitt Feb 26 '17 at 19:38
1

To install a .deb , you should use gdebi to solve the dependencies problem:

sudo apt-get install gdebi
sudo dpkg --add-architecture i386
sudo aptitude update
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo gdebi skype-install.deb
sudo ln -s /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1 /usr/lib/i386-linux-gnu/
skype

Source

Problems starting Skype

When starting Skype, a native 32 bit binary, in a 64 bit environment you might run into the following error and Skype refuses to start:

ln -s /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1 /usr/lib/i386-linux-gnu/

Edit

Remove/comment the unstable sources from your /etc/apt/sources.list

Create a /etc/apt/preferences file with the following contents:

Package: *
Pin: release a=stable
Pin-Priority: 1001

Run :

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
  • No, this will not work, Already tried, get me - Cannot install 'libqt4-dbus:i386' I think Stephen Kit mention that it is probably some pinning problem. – alex_mike Feb 26 '17 at 19:50
  • @alex_mike Your kernel is installed from backports , Stephen and Jordanm are right about the sources.list and the pining – GAD3R Feb 26 '17 at 21:46
  • Yes, i'm already has the same /etc/apt/preferences file, it was on one of the forum, it is not helping me, I posted my source list. – alex_mike Feb 26 '17 at 23:25
  • @alex_mike Can you add the output of apt-show-versions | grep testing – GAD3R Feb 27 '17 at 8:24
  • added the output, it is a lot of packages, well I just need the intell driver to work with vulkan, the rest I don't need, so I probably need to downgrade some of them to stable versions, right? – alex_mike Feb 27 '17 at 19:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.