4

Previously posted on Ask Ubuntu. Removed for irrelevancy:

https://askubuntu.com/questions/886963/process-polyhedra-using-100-cpu-thread?

System:

  • Linux Mint 17.3 Cinnamon 64-bit
  • Kernel 3.19.0-32-generic
  • Intel Xeon E3-1231 v3 (4 core, 8 thread)
  • NVIDIA GeForce GTX 950 NVIDIA driver 375.26

I noticed my fans getting a little noisy lately and opened the system monitor to find one of the threads of my 8 thread (4 core) CPU under constant 100% load.

I ran top and got the following result:

image

Polyhedra is the screen saver I've been using for a while but did not have this problem until recently. (Obviously the screen saver itself was not running at the time I took the screenshot. The process continued until I killed it manually in system monitor)

I started scrolling through the screen savers in the settings menu and every time a new xscreensaver screen saver that has 3D graphics was opened in the preview window another CPU thread hit 100% and stayed there until I killed the process:

image

I recently updated NVIDIA drivers (including CUDA) and had trouble installing them on first try from the update manager. I suspect this might be a source of the problem. Does anyone know?

1 Answer 1

0

I found this thread while troubleshooting a similar problem in Mint 18.1. My CPU rarely runs hotter than 33 C. Yesterday, I discovered that temps had climbed to 41 C after two breaks from work. I ran 'top,' discovered 99 - 100% CPU usage by xscreensaver polytopes. Disabling the screensaver fixed the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .