0

I'm on Fedora 25, Gnome shell version 3.22.3. I have changed keyboard layout via GUI Settings -> Region & Language -> Input Sources and adding (and selecting) English (Dvorak) variant.

The weird thing is that the dvorak layout do have effect in gnome-terminal, nautilus etc., but not in many other applications, like gvim, chrome.

Why is it only partially applied? How to apply the new layout globally?


Edit: In "partially applied" Dvorak mode, Gnome keyboard shortcuts are still in their QWERTY positions, e.g., "Super+D" to show desktop.

  • First guess is that it's a Gnome setting via some input method that's only used by Gnome applications. Does the output of xmodmap -pke reflect the Dvorak assignments? – dirkt Feb 25 '17 at 8:03
  • @dirkt No, xmodmap -pke didn't show any difference when toggling between QWERTY and Dvorak. By the way, localectl output didn't change either (shouldn't X11 variant show up?) – Naitree Feb 25 '17 at 8:22
  • So for X global settings, why not try with setxkmap (and convert to xorg.conf config) like e.g. here in the answer with grp:alt_shift_toggle? (If you don't want to toggle, you can simplify it, of course). I've no idea how this interacts with the Gnome settings, though, you may have to expirement. – dirkt Feb 25 '17 at 9:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.