2

Good day everybody recently I've installed Arch on my computer and I'm still trying to figure it out why are the mounted devices (HDD) are missing from the Home folder tree in my File manager? To see it more clear what I mean:

basic

but when I run it with sudo I get this view:

root

I'm assuming I must be missing some permissions for this?

All extra devices are mounted to /mnt folder which in properties indicates root as the owner.

How can I make it look the same without running sudo?

UPDATE

cat /etc/fstab

# /etc/fstab: static file system information
#
# <file system> <dir>   <type>  <options>   <dump>  <pass>
# UUID=7b8195aa-4480-433e-b258-7b5607977dbb
/dev/sda1               /           ext4        rw,relatime,data=ordered0 1

# UUID=dec7470a-c024-4f87-aa38-03d1d0bc214c
/dev/sda5               /home       ext4        rw,relatime,data=ordered0 2

# UUID=e2fc4ba5-3b2a-4dd8-9d35-eba0d1f83fc2 LABEL=Movies
/dev/sdb1               /mnt/movies     ext4        rw,relatime,data=ordered0 2

# UUID=4eafe188-0b7d-4083-9ef2-c3370e881455 LABEL=Media
/dev/sdb2               /mnt/media      ext4        rw,relatime,data=ordered0 2

# UUID=bb278797-cdd3-4f28-acb8-809935e48bb9
/dev/sda6               none        swap        defaults    0 0

sudo blkid

/dev/sda1: UUID="7b8195aa-4480-433e-b258-7b5607977dbb" TYPE="ext4" PARTUUID="3cde3cdd-01"
/dev/sda5: UUID="dec7470a-c024-4f87-aa38-03d1d0bc214c" TYPE="ext4" PARTUUID="3cde3cdd-05"
/dev/sda6: UUID="bb278797-cdd3-4f28-acb8-809935e48bb9" TYPE="swap" PARTUUID="3cde3cdd-06"
/dev/sdb1: LABEL="Movies" UUID="e2fc4ba5-3b2a-4dd8-9d35-eba0d1f83fc2" TYPE="ext4" PARTUUID="0008db75-01"
/dev/sdb2: LABEL="Media" UUID="4eafe188-0b7d-4083-9ef2-c3370e881455" TYPE="ext4" PARTUUID="0008db75-02"

UPDATE 2

cat /etc/fstab

# /etc/fstab: static file system information
#
# <file system> <dir>   <type>  <options>   <dump>  <pass>
# UUID=7b8195aa-4480-433e-b258-7b5607977dbb
/dev/sda1               /           ext4        rw,relatime,data=ordered0 1

# UUID=dec7470a-c024-4f87-aa38-03d1d0bc214c
/dev/sda5               /home       ext4        rw,relatime,data=ordered0 2

# UUID=e2fc4ba5-3b2a-4dd8-9d35-eba0d1f83fc2 LABEL=Movies
                    /mnt/movies     ext4        rw,user,auto,acl            0 2

# UUID=4eafe188-0b7d-4083-9ef2-c3370e881455 LABEL=Media
                    /mnt/media      ext4        rw,user,auto,acl            0 2

# UUID=bb278797-cdd3-4f28-acb8-809935e48bb9
/dev/sda6               none        swap        defaults    0 0


mount | grep sdb

/dev/sdb2 on /run/media/admin/Media type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)
/dev/sdb1 on /run/media/admin/Movies type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)
  • You mount them over /etc/fstab ? – user192526 Feb 25 '17 at 18:12
  • Yes they are mounted and present in /etc/fstab as I said when I launch File Manager with root privileges I can see them mounted as on the screenshot above. – JoKeR Feb 26 '17 at 17:26
  • Then edit your question cat /etc/fstab and with sudo or as root blkid – user192526 Feb 26 '17 at 19:01
  • sorry for the hold up... the outputs added – JoKeR Mar 8 '17 at 1:17
2

Change this Entries

# UUID=e2fc4ba5-3b2a-4dd8-9d35-eba0d1f83fc2 LABEL=Movies
/dev/sdb1               /mnt/movies     ext4        rw,relatime,data=ordered0 2
# UUID=4eafe188-0b7d-4083-9ef2-c3370e881455 LABEL=Media
/dev/sdb2               /mnt/media      ext4        rw,relatime,data=ordered0 2

to

LABEL=Media  /mnt/media      ext4  rw,user,auto,acl   0 2     

LABEL=Movies /mnt/movies     ext4  rw,user,auto,acl   0 2  

The Option x-gvfs-show is also a possibility as daisy wrotes, but personal I don't like it. It is no good Idea to mount over /dev/device-nodes. Better is over UUID or LABEL. It identifies a special partition. And only for that partition the entry in /etc/fstab effect.

  • ok it works now! removing /dev/sdb1 and 2 solved it... but still what is the issue if /dev/sdb is listed in fstab file? And one more thing now I can see my devices in Home folder tree but when I click on it every time after reboot it asks for root password? – JoKeR Mar 8 '17 at 12:41
  • Again cat /etc/fstab and mount | grep sdb – user192526 Mar 8 '17 at 12:47
  • output added... – JoKeR Mar 8 '17 at 23:36
1

Does it work if you add x-gvfs-show to fstab? e.g

UUID=5a1615ca-cffd3124917a /mnt/storage ext4 rw,noatime,discard,x-gvfs-show 0 2

P.S you can also mount disks with udisksctl command, e.g udisksctl mount -b /dev/sdb2 -t ext4, which will show normally in modern File Manager

0

Solved! ok I'll contribute my answer to this thread maybe it will help somebody else with the same issue.

So there's a quick workaround to this but I'll try to reproduce my steps.

Firstly my fstab looked like this:

# UUID=e2fc4ba5-3b2a-4dd8-9d35-eba0d1f83fc2 LABEL=Movies
/dev/sdb1               /mnt/movies     ext4        rw,relatime,data=ordered0 2

But thanks to @Bahamut I managed to change it to this and mountable devices appeared on Home folder tree:

# UUID=e2fc4ba5-3b2a-4dd8-9d35-eba0d1f83fc2 LABEL=Movies
                    /mnt/movies     ext4        rw,user,auto,acl            0 2

After that I changed it again to:

# UUID=e2fc4ba5-3b2a-4dd8-9d35-eba0d1f83fc2 LABEL=Movies
                    /mnt/movies     ext4        uid=1000,gid=100,umask=0022,auto,nosuid,nodev,rw,relatime,data=ordered  0 2

Only for the security meassures you can read more on fstab here Do note! that uid and gid may differ in your system from example above.

But now I faced the issue every time I reboot the system it will ask for the root password which is kinda annoying but yes might be good for the security meassures.

I started to google for the workaround and found a solution to edit sudoers file to remove sudo when using with mount but that is highly not recommended for the security purpose so I skipped this workaround and not recommend it either.

So after I clicked on partition icon to mount it the pop up window appeared

popup

And at the left bottom corner I clicked Details Action which showed: org.freedesktop.udisks2.filesystem-mount-system

As I found out later it appears to be a policy rule but one can change it just run in terminal:

sudo gedit /usr/share/polkit-1/actions/org.freedesktop.udisks2.policy

you can use nano as well or your fav. and in opened window search for the lines:

<action id="org.freedesktop.udisks2.filesystem-mount-system">

    <defaults>
      <allow_any>auth_admin</allow_any>
      <allow_inactive>auth_admin</allow_inactive>
      <allow_active>auth_admin_keep</allow_active>
    </defaults>
  </action>

and change it to:

    <defaults>
      <allow_any>yes</allow_any>
      <allow_inactive>yes</allow_inactive>
      <allow_active>yes</allow_active>
    </defaults>
  </action>

Save & close the file.

now sudo reboot

That's it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.