After some update, the annoying and frustrating situation is the following.

  • After each reboot the update icon shows the blue circle with '1' inside it; if I click on it, the update manager opens and shows the welcome screen
  • I use custom font and colors in the terminal. After having set this options, if I open another instance of the terminal before closing the first one, it "inherits" the setting I chose, but if I close every instances and then open again, these settings are forgotten, so I have to set them again (font, size, colors, "don't show menu bar", ...).
  • If I click on the desktop and press F5, the icons are disorderly put near the left edge of the main screen, like this: enter image description here (I can reorder them by right-click > sort icons by name).
  • If I right click on the desktop and then on desktop settings, I cannot change any desktop setting: not the Computer/Home/Trash/Volumes/Network icons' visibility, nor the "show icons on the main/secondary screen", not even can I change the wallpaper! Not even the theme, the color of the icons, and so on!
  • In the right part of the menu bar I see removable unit icon, which, if hit, shows "file system radice" (radice is root) and "home", that you can also see in the preceding screenshot. (I cannot remove neither of them; maybe it's normal, but I never had this icon in the menu bar with no external drive connected. enter image description here
  • I cannot even change the setting of the menu bar (to make it hide automatically, for instance).

I think I could add a lot of other examples, but the main point is: no matter what setting do I change, nothing happens!


Here's the output of the command, as suggested by @Bahamut.

...$ find $HOME -user root
find: "/home/enrico/.cache/dconf": Permesso negato


...$ env | grep -i session
  • 1
    any output find $HOME -user root
    – user192526
    Feb 25, 2017 at 11:11
  • @Bahamut, I edited the question adding the info you asked for.
    – Enlico
    Feb 25, 2017 at 12:37
  • Hm, sudo chown -hR $USER:$USER $HOME/.cache/dconf Logout and login again.
    – user192526
    Feb 25, 2017 at 13:18
  • Nothing's changed, except that the output of the previous command consists now only of the 1st, 2nd, and last lines.
    – Enlico
    Feb 25, 2017 at 13:27
  • Which Desktop is this? I thought mate or cinnamon? env | grep -i session
    – user192526
    Feb 25, 2017 at 13:29

1 Answer 1


Not a clean solution, more a workaround. In the chat we found out, that Enlico build a Software from the sources, that install some libaries in /usr/local/lib.

ldd /usr/lib/x86_64-linux-gnu/gio/modules/libdconfsettings.so

linux-vdso.so.1 => (0x00007fffa2c2d000)
libgio-2.0.so.0 => /usr/local/lib/libgio-2.0.so.0 (0x00007f1037207000)
libgobject-2.0.so.0 => /usr/local/lib/libgobject-2.0.so.0 (0x00007f1036fb6000)
libglib-2.0.so.0 => /usr/local/lib/libglib-2.0.so.0 (0x00007f1036ca5000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f1036a5c000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f1036693000)
libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f103648a000)
libgmodule-2.0.so.0 => /usr/local/lib/libgmodule-2.0.so.0 (0x00007f10362870


After rename a file in /etc/ld.so.conf.d/ that the installer created and change the

# libc default configuration
# /usr/local/lib

this way and running sudo ldconfig The issue is fixed for the moment.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .