1

after one problem, I have a second... So, my computer configuration is:

  • Operating System: Dual Boot Windows 10 and Debian 8 Jessie (64 bit)
  • Motherboard: Asus Z170 PRO Gaming
  • Graphic card: Nvidia GTX 1080 (Reference/Founder Edition)
  • Processor: Intel I7-6700K

    Memory: 16 GB - 2 x 8GB 3200 mhz (probably crucial, I forgot...)

  • Hard Discs: SSD m.2 512 GB Liteon (NVMe, Debian 8 Jessie) SSD MX300 1050 GB

    (Windows 10 installed)

  • SSD OZ SATA 2 30 GB (nothing already installed, but I will add this space

later to my Debian for testing, sandbox, etc...)

  • Monitor: Dell U3415W (21:9) - SPEAKERS BUILT IN (the only)

    xx@xx: netcool@netcool:~$ lspci -nn

    00:00.0 Host bridge [0600]: Intel Corporation Device [8086:191f] (rev 07)
    
    00:01.0 PCI bridge [0604]: Intel Corporation Device [8086:1901] (rev 07)
    
    00:14.0 USB controller [0c03]: Intel Corporation Device [8086:a12f] (rev 31)
    
    00:16.0 Communication controller [0780]: Intel Corporation Device [8086:a13a] (rev 31)
    
    00:17.0 SATA controller [0106]: Intel Corporation Device [8086:a102] (rev 31)
    
    00:1b.0 PCI bridge [0604]: Intel Corporation Device [8086:a167] (rev f1)
    
    00:1c.0 PCI bridge [0604]: Intel Corporation Device [8086:a110] (rev f1)
    
    00:1d.0 PCI bridge [0604]: Intel Corporation Device [8086:a118] (rev f1)
    
    00:1f.0 ISA bridge [0601]: Intel Corporation Device [8086:a145] (rev 31)
    
    00:1f.2 Memory controller [0580]: Intel Corporation Device [8086:a121] (rev 31)
    
    00:1f.3 Audio device [0403]: Intel Corporation Device [8086:a170] (rev 31)
    
    00:1f.4 SMBus [0c05]: Intel Corporation Device [8086:a123] (rev 31)
    
    00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (2) I219-V [8086:15b8] (rev 31)
    
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:1b80] (rev a1)
    
    01:00.1 Audio device [0403]: NVIDIA Corporation Device [10de:10f0] (rev a1)
    
    03:00.0 USB controller [0c03]: ASMedia Technology Inc. Device [1b21:1242]
    
    04:00.0 Non-Volatile memory controller [0108]: Broadcom Corporation (Wrong ID) Device [14a4:2200] (rev 01)
    

I have no sound... I tried few solutions provided on ubuntu/debian forum however without success. I have below error messages:

xx@xx: pulseaudio -D

E: [pulseaudio] main.c: Daemon startup failed.

xx@xx: /usr/lib/pulse-5.0/modules$ pulseaudio -vvv

I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted

I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted

D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.

D: [pulseaudio] core-util.c: RealtimeKit worked.

I: [pulseaudio] core-util.c: Successfully gained nice level -11.

I: [pulseaudio] main.c: This is PulseAudio 5.0

D: [pulseaudio] main.c: Compilation host: x86_64-pc-linux-gnu

D: [pulseaudio] main.c: Compilation CFLAGS: -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -Wall -W -Wextra -pipe -Wno-long-long -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -fno-common -fdiagnostics-show-option

D: [pulseaudio] main.c: Running on host: Linux x86_64 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u1 (2017-02-22)

D: [pulseaudio] main.c: Found 8 CPUs.

I: [pulseaudio] main.c: Page size is 4096 bytes

D: [pulseaudio] main.c: Compiled with Valgrind support: no

D: [pulseaudio] main.c: Running in valgrind mode: no

D: [pulseaudio] main.c: Running in VM: no

D: [pulseaudio] main.c: Optimized build: yes

D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.

I: [pulseaudio] main.c: Machine ID is 4a1dd43fc10a480d9b8cffbce001c867.

I: [pulseaudio] main.c: Session ID is 1.

I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.

I: [pulseaudio] main.c: Using state directory /home/netcool/.config/pulse.

I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-5.0/modules.

I: [pulseaudio] main.c: Running in system mode: no

E: [pulseaudio] pid.c: Daemon already running.

E: [pulseaudio] main.c: pa_pid_file_create() failed.

I tried pulseaudio --kill, start etc, and I'm not able to see any changes.

I'm using my monitor dell U3415W as an audio (audio built in), however in the audio setting.

When I run the pavucontrol, for Output Devices, I can only see 2 entries:

  1. "HDA Nvidia Digital Stereo (HDMI)": Port: HDMI / DisplayPort (unplugged)

and

  1. "Built-in Audio DIgital Stereo (IEC958) Port: Digital Output (S/PDIF)

When I'm going to "Configuration" Tab, I can see that for HDA Nvidia (1) everything is "unplugged".

When I'm pressing volume up button on keyboard occured Digital Output (S/PDIF).

My monitor is connected to the PC via mDP.

PS: It's not working via root and standard user.

Best Regards.

  • (1) According to the second last line of pulseaudio -D, it's already running (verify with ps axu), so you don't need to start it. (2) If you haven't installed it, try using the proprietary nvidia graphics driver, in the hope that it can drive the HDMI output correctly. (3) When you test audio, make sure in pavucontrol it uses the right output, even if it is marked "unplugged". – dirkt Feb 24 '17 at 18:01
  • Dirkt, I already installed nvidia graphic drivers as my first problem was incorrect resolution, I don't want to mess with it again if it is not necessary. For: "make sure in pavucontrol it uses the right output, even if it is marked "unplugged" - I will check that at the morning, however all entries are (HDMI), but my monitor is connected by Mini Display Port cable not a HDMI, so it shouldn't be visible as "mDP" instead of "HDMI"? – Veroker Feb 24 '17 at 23:19
  • Ok, let's figure out the driver. Do aplay -l, you'll see a list of card X: ... , device Y .... Pick X and Y for your mDP port (or all possibilities you see), Look for a file /sys/class/sound/pcmXDYp (with numbers for X and Y). Do udevadm info -a /sys/class/sound/pcmXDYp | grep DRIVER. If the output doesn't make sense, put output of aplay -l and udevadm ... without grep into a pastebin and let me have a look at it. HDMI and DP are similar enough that they can use most of the same hardware, so it'd show up as an HDMI port. – dirkt Feb 25 '17 at 7:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.