im running xdg-user-dirs-update command, which create two files in .config directory, user-dirs.dirs and user-dirs.locale. user-dirs.dirs lookes like this:

# This file is written by xdg-user-dirs-update
# If you want to change or add directories, just edit the line you're
# interested in. All local changes will be retained on the next run
# Format is XDG_xxx_DIR="$HOME/yyy", where yyy is a shell-escaped
# homedir-relative path, or XDG_xxx_DIR="/yyy", where /yyy is an
# absolute path. No other format is supported.

why its empty even after changing XDG_DESKTOP_DIR="$HOME/" to XDG_DESKTOP_DIR="$HOME/Desktop" directories still not creating why? how can i get my full home dirs back?


You forgot the Folder.

Example XDG_DOWNLOAD_DIR="$HOME/Downloads" In /etc/xdg/user-dirs.defaults You can show the names of the standart folder. Correct your File and run xdg-user-dirs-update again. The right locale for you will be set automatical.

| improve this answer | |
  • 1
    that's the problem even after i add folder names like $HOME/Dowloads, and when i run xdg-user-dirs-update i'm getting the message: /home/void/Desktop was removed, reassigning DESKTOP to homedir – vimbob Feb 23 '17 at 15:48
  • which distrie ? env | grep -i xdg – user192526 Feb 23 '17 at 18:29

xdg-user-dirs-update is part of the answer, but its default behavior is to reassign missing directories to $HOME, not recreate them.

To recreate the directories, do this:

xdg-user-dirs-update --force

Depending on your desktop environment, You may have to logout/login to get the emblems in your file manager.

| improve this answer | |
  • 1
    That's the answer, it even adresses this comment. – Felipe S. S. Schneider Oct 8 at 12:28
  • 1
    @FelipeS.S.Schneider thank you for your appreciation of my answer. The standard practice in this case is to upvote the answer (in practice, by clicking on the triangle upwards next to the beginning of the answer). – Stéphane Gourichon Oct 9 at 18:19
  • +1 I certainly did! – Felipe S. S. Schneider Oct 9 at 18:43
  • 1
    Ah yes I see it now. Initially it seems like you did not, sorry for the noise. – Stéphane Gourichon Oct 9 at 20:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.