37

I already got this installed:

1 core/archlinux-keyring 20170104-1 [installed]
10 blackarch/blackarch-keyring 20140118-3 [installed]

But I get an error when upgrading libc++abi from AUR:

==> Verifying source file signatures with gpg...
    llvm-3.9.1.src.tar.xz ... FAILED (unknown public key 8F0871F202119294)
    libcxx-3.9.1.src.tar.xz ... FAILED (unknown public key 8F0871F202119294)
    libcxxabi-3.9.1.src.tar.xz ... FAILED (unknown public key 8F0871F202119294)
==> ERROR: One or more PGP signatures could not be verified!
==> ERROR: Makepkg was unable to build libc++.
==> Restart building libc++abi ? [y/N]

How to resolve this? Is there a way to know which keyring I should install to solve this issue?

3 Answers 3

73

gpg --recv-keys 8F0871F202119294 (AUR)

  • the missing key needs to be added to your USER keyring

I did not need to trust the key for makepkg to finish the build.

  • ~/.gnupg/gpg.conf also needed:

keyserver-options no-honor-keyserver-url

in my particular case


  • Missing keys for official Arch repos are normally missing an updated archlinux-keyring
3
  • 3
    I was so proud of myself for remembering the command pacman-key --recv-keys KEY, and so sad when it didn't work. I see that it's my user keyring that needs adjusting, not the pacman keyring. Thanks! Apr 18, 2019 at 17:38
  • i also needed to create that conf file and add that line
    – austin
    Mar 18, 2022 at 2:51
  • and i had to download and import their public key
    – austin
    Mar 18, 2022 at 2:58
14

Keys from AUR are not in the keyrings provided by the distributions' repositories.

You will need to find and add the AUR package/upstream keys manually, if you trust them.

Start by checking the PKGBUILD file of the package, then the comments in the AUR to see where/if to get and add the keys.

0
-1

Try: sudo pacman -U /path/to/file.tar.xz

Do that for all of the file types, then try your upgrade again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .