2

Situation : I have installed two Linux Mints OSs on my computer, I'm using the first one for normal use (Browsing, Watching Movies, ...), I use the second one for my programming work, So I always hibernate the second one, to do not lose my opened windows (More than 15 windows).

Problem : So my problem is after hibernating the second one, when I restart to open the first OS it resume the second one (Programming OS).

Solution (didn't work) : I tried to disable mounting the swap partition at startup from the first OS, but that did stop it just from using the swap

  • 1
    Have you removed swap entry from OS one fstab ? – sgargel Feb 22 '17 at 9:25
  • Can you not set windows to reopen on login? – forquare Feb 22 '17 at 10:37
  • 2
    You could create a separate swap file just for hibernation – DarkHeart Feb 22 '17 at 12:06
  • The windows are (Atom, A lot of terminals, .....), they take a long time to reopen – Khalil Bz Feb 22 '17 at 12:06
  • @DarkHeart Could I make it for ever I mean after making the OS swap into a file, Do I have to redo the configuration each startup ?, I wish you change your comment into an answer, It seems to be a good solution – Khalil Bz Feb 22 '17 at 12:13
4

As you know, when you hibernate it saves the contents of memory (most of it) to the swap partition. It sounds like that this partition is shared between the two OS instances.

A possible solution could be using a swap file for the one you want to hibernate (assuming you don't want to create another swap partition). There are some extra options for this, see here: https://wiki.archlinux.org/index.php/Power_management/Suspend_and_hibernate#Hibernation_into_swap_file

This gives you the advantage of having a separate file just for hibernate and use the partition just for swapping.

3

The best solution would be not to dual boot at all, but have the programming OS in a virtual machine instead.

Then you can pause/unpause the programming system at any time as well as enjoying the benefit of easily making snapshots of the system you use for work, making data and progress loss a lesser risk.

  • Thank you so much for your help, But I already did that but When I use Linux Mint as a VM, it works very slowly (I have i3 Pross and 8GB RAM and Windows OS works very good as a VM the problem only with LINUX as a VM), I wish you help me sir – Khalil Bz Feb 22 '17 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.