1

I'm trying to get snapraid to do it's first sync, but about a minute in it always hits a sparseimage from one of my drives and spits out a bunch of 'Input/Output error in file' errors. The weird part is then, one or more of my drives go into read-only mode (I have six 4tb storage drives and one 1tb system drive).

After googling, read-only seems to be a mode that drives go into when there's a file system error. Earlier today, fsck was showing 'attempt to read block from file system resulted in a short read while trying to open /dev/...'. The REALLY strange thing is after a restart, none of my drives were showing any issues with Fsck. It was only once I attempted a sync that things went haywire...

I just tried restarting, unmounting, and running sudo fsck.ext4 -v /dev/... and I get fsck .ext4: Bad magic number in super-block while trying to open /dev/.... This is the case with all six of my 4TB drives though. These drives were bought at different times.... Again, the drives mount and work perfectly fine until I run fsck or snapraid sync.

What could be causing this? I've been using these drives for weeks with zero issues, it was only once I try to snapraid sync that everything falls apart..

Possibly pertinent info: I'm mounting to /media/StorageDiskX using UUIDs in my fstab*

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.