I have been using XFCE on and off before but in the last 4 years it has been a constant companion along with Debian (currently Jessie), which I am running as my OS of choice in these past 4 years.

I have noticed that Thunar has this weird thing going on when it comes to the width of the columns that provide metadata. I have no idea how this value is determined internally but it keeps changing even inside folders that I haven't touched in a long time.

I have read here that metadata is stored by Thunar but I have no idea whether the length of each file name is stored (frankly, don't want to; I just want things to work...).

Most of the time it's the Name column that is screwed up but it's not uncommon to see the same issue with other columns as well. Sometimes this column's width is too tiny and only a portion of the file names are visible. In other situations it is too long (like 6-7 times wider than the longest file name in it).

Is there anything that I can do to change that? I wouldn't mind having each column be as wide (plus some more space for better readability) as the longest file name. Thunar isn't exactly amazing when it comes to its settings menu but perhaps there is some hidden (as in inaccessible through its UI) setting that I have missed?

  • I'm seeing this in Xfce on Arch (Thunar 1.6.12), a workaround: stretch the width of the Thunar window, set the other (non-wonky) column widths as you want, then shrink the width of the window. This will force the name column to reduce its size.
    – mcalex
    Aug 2, 2017 at 20:17

1 Answer 1


Deactivate "Automatically expand columns as needed" in Thunar's menu "View" > "Configure Columns".

Source: https://askubuntu.com/questions/405369/thunar-doesnt-save-settings-on-exit

That does work for me so far.

  • 1
    This is enabled by default (including in my Debian 8) but it doesn't work. Perhaps you have a newer version? Mine is 1.6.3. May 1, 2017 at 14:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .