2

On Fedora 25, xinput seems to have problems recognizing properties for input devices.

According to ThinkWiki, this should work:

$ xinput set-prop "TPPS/2 IBM TrackPoint" "Device Accel Profile" 2
property 'Device Accel Profile' doesn't exist, you need to specify its type and format

Looking at the output in Setup section below, it seems, that the properties were renamed. Unfortunately, using the new property names yields the same result:

$ xinput set-prop "TPPS/2 IBM TrackPoint" "Accel Speed" 0.75
property 'Accel Speed' doesn't exist, you need to specify its type and format

I also tried using the device id with --type and --format specified - same result.

Setup

Fedora 25, Xorg (not Wayland), i3wm, Thinkpad TrackPoint (TPPS/2 IBM TrackPoint)

$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                     id=10   [slave  pointer  (2)]
...

$ xinput list-props 'TPPS/2 IBM TrackPoint'
Device 'TPPS/2 IBM TrackPoint':
    Device Enabled (139):   1
    Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Accel Speed (276): 0.000000
    libinput Accel Speed Default (277): 0.000000
    libinput Accel Profiles Available (278):    1, 1
    libinput Accel Profile Enabled (279):   1, 0
    ...
1
  1. The property is called libinput Accel Speed (note the libinput at the begging). Similarly with other properties.
  2. The input devices are now handled by libinput library (at least in Fedora 25), which supports both Wayland and X.Org. Unfortunately, it does note provide as much options as the old way (yet! - it seems to be in rapid development).

Notes

  • man libinput documents all the properties
  • ArchWiki makes a great topic summary as always
  • There seems to be a workaround to fall back to the old method, but I did not try it.

Since I am replying to my own question, I might have missed something important - all input appreciated.

EDIT Completely forgot to mention that the TrackPoint scrolling works out of the box now, which is kind of nice :)

  • Whoa, works out of the box? Not on my ThinkPad E470 running Fedora 25. You didn't end up needing to change any settings to get it working now? – dmh May 28 '17 at 14:28
  • @dmh Yes, but I do have quite old ThinkPad. – NefariousOctopus May 28 '17 at 22:05
  • Ah, okay. Well, at least fc26 is out in a couple of months. Hopefully it works for me by then... – dmh May 30 '17 at 8:49
  • Trackpoint scrolling (using middle key) doesn't quite work for me as it used to before (it works in reverse order). It happened after i upgraded from fc25 to fc26. Still cannot figure out. – sherzodr Dec 10 '17 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.