5

I'm debugging a kernel module under VirtualBox with a guest and host OS as Ubuntu 10.10. I'm using the virtualbox serial port but I'm maxing out at the baudrate 115200. My grub config looks like this...

console=ttyS0,115200

Is there a way for me to change that setting in the guest OS so that the virtual serial port works at a faster baudrate? I've tried to use setserial. That didn't give me an error, but when I recompiled with a faster baudrate for the console I didn't see a change.

Thanks!

  • It looks like that virtual serial port works only at 9600 and ignore all the settings – vitaly.v.ch Sep 5 '17 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.