9

I am trying to login on my laptop. I write the password and then I am logged in to a black page, where a notice said

"Your session only lasted less than 10 seconds. If you have not logged out yourself, this could mean that there is some installation problem or that you may be out of the diskspace. Try logging in with one of the failsafe sessions to see if you can fix this problem."

the code says:

initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: connection refused mdm[1699]: GLib-CRITICAL: g_key_file_free: assertion 'key_file != NULL' failed

The only button available is "Okay", the I return to the login page where I should write my password again. It keeps repeating it self again and again. I don't understand why??!

One day ago, there was a new update for the system. I did update it. Can this be the reason??

Thank you for your help in forward.

4
  • Upgrade from Mint 17 or fresh installation?
    – user192526
    Commented Feb 20, 2017 at 11:15
  • @Bahamut no an update in the update center. It was called a Kernal update.
    – NekoMisaki
    Commented Feb 20, 2017 at 11:32
  • 1
    Hm. press STR+ALT+F2 and login. sudo dpkg --configure -a && sudo apt update && sudo apt -f install Maybe update was interrupted
    – user192526
    Commented Feb 20, 2017 at 11:38
  • Yes something was interrupted. The Cinnamon was not installed somehow. Thanks a lot for the help.
    – NekoMisaki
    Commented Mar 5, 2017 at 13:57

3 Answers 3

8

In my case I had installed virtualbox-guest-x11 on the base box so I had messed up x11 drivers. So I was getting this error message on $HOME/.xsession-errors:

initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused syndaemon: no process found /etc/mdm/Xsession: Beginning session setup... localuser:raskolnikov being added to access control list

I removed the package and re-installed cinnamon.

aptitude remove virtualbox-guest-x11 -y aptitude install cinnamon -y

Restarted the box and it worked.

4
  • I had today the problem again and tried your solution. After I removed the virtualbox I tried to install but the packages were all installed. So I think the first code is the solution. Thanks anyway 👍🏻
    – NekoMisaki
    Commented Apr 5, 2018 at 8:57
  • 1
    Agreed with @nekomisaki just removing virtualbox worked. Commented Apr 9, 2018 at 13:53
  • 1
    Great that my solution is helping so many people. I took me a few hours to found out what was happening. Commented Apr 9, 2018 at 20:43
  • I would add this is how you get to terminal to do this fix: To get full screen command line you can use Ctrl+Alt+F(1-6). That gives you up to 6 different full screen sessions. You can switch to the graphical session by Ctrl+Alt+F8 and switch between all of them using the keyboard. (borrowed from: forums.linuxmint.com/viewtopic.php?t=252672)
    – Patrick
    Commented Nov 11, 2018 at 2:35
6

There seems to be a problem with the most recent update of virtualbox-guest-x11.

I'm running Mint 18 Sarah, Mate edition, and after that update (27 or 28 March 2018) I had lost most of my icons from my panel, could not use any GUI tools to look at my network or printers and could not launch many of my applications, including Chromium, Firefox, Thunderbird, Xreader and Synaptic. The unlaunchable applications would give no error messages when I tried launching them, regardless of whether I tried as myself or as root, from the GUI or from the terminal, with or without -v or -vv.

A member of a local Linux user group directed me to this board. I ran

sudo apt-get purge virtualbox-guest-x11

and everything returned to 'normal'. I did not even have to reinstall the Mate desktop.

1
  • Thanks for sharing. I did not even need to restart my box. After removing the driver, the next login attempt worked. I'm using Cinnamon.
    – Scolytus
    Commented Apr 22, 2018 at 19:57
2

I don't know what you have done, but one thing is confirmed that some files were missed, which cause xwindow can't start normally. The solution is reinstalling the xwindow to make up the missing files. Try Ctrl+Alt+F1 to open another shell, then

sudo apt-get install cinnamon
sudo reboot

until get the GUI start up. It takes minutes, be patient, good luck.

2
  • Thank you for replying. That was exactly the problem. Cinnamon was somehow not installed.
    – NekoMisaki
    Commented Mar 5, 2017 at 13:55
  • Happy to help you.
    – Jactor
    Commented Mar 6, 2017 at 13:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .