7

I searched pretty thoroughly and I could only find posts in which people have keyboard mappings that are wrong system-wide, however I have a bizarre situation in which most applications work OK, but some are completely wrong:

I am running Ubuntu 16.04 server with xfce installed (never had Unity/GNOME). I am running tightserver.

I remote in and everything that comes with xfce seems to work. I installed various applications.

The following do work: - gedit - firefox - filezilla - gimp

The following do not work:

  • notepadqq
  • qbittorrent

in notepadqq I get the following (left is keypressed, right is key displayed)

a=a
b=s
c=d
d=f
e=g

(if important I will make full list)

I feel like there most be something very specific that would cause this, that is I don't think it has anything to do with processor load/hardware glitch/power fluctuation. Why would specific applications behave this way?

7
  • Notepadqq and qbittorrent both use the Qt library, so the common factor is presumably some Qt bug or strange configuration. Can you try other Qt/KDE to check if they're also failing? What keyboard layout do you use and how is it configured? Where (what OS and client software) are you remoting from and can you reproduce the problem locally or with a different way of remoting? Commented Feb 19, 2017 at 19:33
  • 1
    The following Clients all have the same problem: Windows RealVNC Windows TightVNC OSX RealVNC OSX native screenshare
    – Jesse Adam
    Commented Feb 20, 2017 at 21:11
  • @Gilles I'm having trouble getting Qt programs to install, Filezilla works (I don't know if it still uses Qt), I installed Qt configuration tool and that seems OK, is there a specific program you recommend I try?
    – Jesse Adam
    Commented Feb 21, 2017 at 3:17
  • Filezilla doesn't use Qt. The Qt configuration tool does. That's quite a mysterious bug here. Have you found a client that doesn't have this bug? Can you try remoting with something other than tightvncserver? It would help to figure out whether the problem is on the server side or on the client side. Commented Feb 21, 2017 at 12:36
  • I know this is an old-ish thread, I've just seen this exact same problem with Virtualbox Manager on a brand new minimal Ubuntu server running XFCE over tightvncserver. All the locale was there, keyboard mapping perfect on most apps but Virtualbox character input was as described above. Took me an age to find this post; I solved my problem by using vnc4server instead of tightvncserver (no change to client) and everything now working perfectly.
    – Aitch
    Commented Jun 2, 2017 at 11:18

3 Answers 3

7

This sounds very much like a known bug: TightVNC doesn't support XKEYBOARD, which confuses Qt5. (XKEYBOARD is one of several widely-supported extensions to the original X11 protocol.) The bug report against the Qt project has a comment that states that it is unlikely to be fixed because lack of XKEYBOARD is rare. The Debian bug report suggests using TurboVNC instead of TightVNC; it's a fork of TightVNC which implements some additional extensions including XKEYBOARD.

1
  • This should be the accepted answer; in my case on Ubuntu Server (with minimal XFCE install) and tightvncserver, switching to vnc4server similar to suggestion above fixed the problem immediately.
    – Aitch
    Commented Jun 2, 2017 at 11:20
1

TigerVNC might also be an option. I find the server to be faster and the client to be simple but adequate for most requirements.

1
  • did not WFM for whatever reason, but vnc4server wrapper on tiger DOES work...
    – math
    Commented Feb 21, 2022 at 22:13
0

vnc4server meta-package in Devuan works fine for me. Seems to be a wrapper to tigervncserver, but somehow that did not wfm without the vnc4server.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .