1

I am running Gentoo Linux Hardened with kernel 4.8.17-r2 on an AMD FX 8350 using a Radeon RX 480 video card (amdgpu), and for desktop environment I use MATE 1.12.1. I recently updated my system with emerge -NDau --with-bdeps=y @world as well as my kernel. In order to do that I had to mask MESA version 12.0.1, because that version depends on the nightly build of LLVM, which is very unstable and fails to compile MESA itself (MESA 11.2.2 builds fine with LLVM 3.7.1-r3).

After performing said update, MATE became extremely slow. Before the update, my windows moved smoothly when dragged; after the update, one cycle of window redraw takes up to 2 seconds (when dragging an almost maximized window). To rule out the possibility of having missed something to recompile I ran an entire system update again, then emerge @module-rebuild, emerge @preserved-rebuild, emerge --depclean and revdep-rebuild, but MATE is still slow. Given that my video card is mid-high-end, this is most definitely a software issue.

This issue seems to be specific to MATE, because other apps such as Firefox or Chromium display their graphics normally, and Youtube videos play smoothly as usual. If I enable software compositing on MATE's configuration, dragging a window results in smooth motion again, but doing so eats about 80% of a CPU core. Globally enabling USE=glamor and rebuilding my affected packages has no impact on MATE's performance.

My Xorg errors and warnings are pasted here below:

root@goldsaw ~ # grep -e '\(EE\)' -e '\(WW\)' /var/log/Xorg.0.log
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    30.336] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    30.336] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    30.336] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    30.336] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    30.336] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    30.435] (WW) Warning, couldn't open module fbdev
[    30.435] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    30.435] (WW) Warning, couldn't open module vesa
[    30.435] (EE) Failed to load module "vesa" (module does not exist, 0)
[    30.483] (WW) Falling back to old probe method for modesetting
[    30.941] (EE) AMDGPU(0): glamor detected, failed to initialize EGL.
[    31.743] (EE) AIGLX error: Calling driver entry point failed
[    31.743] (EE) AIGLX: reverting to software rendering
[    31.877] (EE) Error loading keymap /tmp/server-0.xkm
[    31.877] (EE) XKB: Failed to load keymap. Loading default keymap instead.
[    31.948] (WW) evdev: Logitech Gaming Mouse G502: ignoring absolute axes.
[    31.949] (WW) evdev: HID 04f3:0103: ignoring absolute axes.
  • Just saw that my error messages are revealing a glamor loading failure. I'll try to fix that as specified here: wiki.gentoo.org/wiki/Radeon#Glamor_does_not_load – RAKK Feb 19 '17 at 3:33
  • Just tried globally enabling USE="gbm egl gles2 llvm". After fiddling a little with package-specific USE flags and removing USE=qt5 from Wireshark I got my world set to compile. Didn't work. – RAKK Feb 19 '17 at 5:39
0

Simple reply: your system has too old packages (yes hardened isn't for gaming desktop but for old, stable servers) for your fancy new GPU, kernel is good , but Mesa is needed minimally 13.0 better 17.0+ , also newest libdrm and llvm

PS: instead xorg-video-ati you need xorg-video-amdgpu driver and also llvm-3.9+

or you can try AMDGPU-PRO binary drivers from AMD.

  • I guess that means the only thing I can do is sitting down and patiently waiting for MESA 12 to not depend on the LLVM nightly build... – RAKK Feb 19 '17 at 19:47
  • @RAKK , mesa 12 is too old for this card ...., and not only mesa but whole gentoo hardened graphics stack – mimi.vx Feb 19 '17 at 19:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.