1

I recently upgraded my Arch system to kernel 4.9.8. Upon reboot, I am unable to isolate the graphical target. dmesg gives me this:

[   54.537319] gnome-shell[756]: segfault at 44 ip 00007f312c42b311 sp 00007ffc7c141a10 error 4 in libmutter.so.0.0.0[7f312c355000+12c000]
[   56.011442] NVRM: Your system is not currently configured to drive a VGA console
[   56.011443] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
[   56.011443] NVRM: requires the use of a text-mode VGA console. Use of other console
[   56.011444] NVRM: drivers including, but not limited to, vesafb, may result in
[   56.011444] NVRM: corruption and stability problems, and is not supported.
[   56.012100] nvidia-modeset: Allocated GPU:0 (GPU-26bd7466-7209-5400-b8c1-c33539ed7a9f) @ PCI:0000:01:00.0
[   56.275134] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 16
[   57.023579] gnome-session-f[896]: segfault at 0 ip 00007f7caeb46ce9 sp 00007fff40fd2170 error 4 in libgtk-3.so.0.2200.8[7f7cae864000+6fa000]
[   64.715141] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 0

It looks like there are a few things that could be casuing the issue, but I think fixing the root cause, whatever it is, will fix the other issues. I have tried to Xorg in other ways, including with startx and starting the gdm service. I know segfaults generally can not be fixed by the user, but I wanted to get a second opinion on this and see of anyone else if having the same issues. Thanks!

What I've looked at/tried so far (I haven't downgraded any packages though): https://bugs.archlinux.org/task/51908

https://bbs.archlinux.org/viewtopic.php?id=218580

https://bbs.archlinux.org/viewtopic.php?pid=1467820#p1467820

  • Have you checked the system journal (or the system logs in /var/log if not using journald)? journalctl -b -p err should give you more information. – Mioriin Feb 19 '17 at 0:17
  • Yes thanks for responding, I have pasted the stack trace here: pastebin.com/KqqSvrJg – vespid Feb 19 '17 at 2:33
0

The first major thing I tried was removing then installing gnome and all dependencies with pacman -Rnsc gnome gdm. This didn't work and removed a lot of packages that I needed. Oh well.

I decided to focus on the NVRM part of the error message because the graphics card driver is the lowest level of operation the errors were coming from, so fix that, fix everything, right? The nvidia driver seemed to be causing the problems, and being a fan of open source, I decided to give the nouveau driver a spin. Removing the nvidia driver was a bit of a pain but once I got it removed and nouveau put in place and rebooted, huzzah! A GUI! Now was it perfect? No. Major components were missing and the resolution was set for a 4:3 monitor. But, by looking at the (very long) /var/log/pacman.log I am currently reinstalling missing components by going through the log file and picking the packages the seem important (gnome-control-center, etc). I hope that helps anyone in the same situation!

Also, this might yield a bug report, but I'm not sure if it should be brought to the attention of the Arch package maintainers or the freedesktop.org people. If you feel so compelled to file one, the link to a stack trace is in the comments on the question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.