4

I have a Lenovo g40 that came with Windows 10. It came with a AMD Radeon R5 M230with 2GB dedicated memory.

I just installed Linux Mint 18.1 on it and it installed with no errors, but I can't see the graphics card listed and so I don't think it's in use.

The only time I can see the graphics card listed is by issuing inxi -Fxz, but I guess that doesn't mean it's in use. Here's part of the output:

System:    Host: Lenovo-G40 Kernel: 4.4.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.16.1 (Gtk 3.18.9-1ubuntu3.1)
           Distro: Linux Mint 18.1 Serena
Machine:   System: LENOVO (portable) product: 80JE v: Lenovo G40-80
           Mobo: LENOVO model: Lancer 4A1 v: SDK0J40679 WIN
           Bios: LENOVO v: B0CN93WW date: 07/23/2015
CPU:       Dual core Intel Core i5-5200U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8778
           clock speeds: max: 2700 MHz 1: 2200 MHz 2: 2200 MHz 3: 2200 MHz
           4: 2200 MHz
Graphics:  Card-1: Intel Broadwell-U Integrated Graphics bus-ID: 00:02.0
           Card-2: Advanced Micro Devices [AMD/ATI] Sun LE [Radeon HD 8550M / R5 M230]
           bus-ID: 04:00.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon,intel (unloaded: fbdev,vesa)
           Resolution: [email protected]
           GLX Renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
           GLX Version: 3.0 Mesa 12.0.6 Direct Rendering: Yes

So I know the graphics card is there. However I can't see in in lspci or lshw, which is what matters I think.

Here's the output of lspci|grep VGA

00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)

And here's the output of lshw -C video

  *-display               
       description: VGA compatible controller
       product: Broadwell-U Integrated Graphics
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:49 memory:d0000000-d0ffffff memory:c0000000-cfffffff ioport:5000(size=64)

I installed the intel-microcode on the driver manager. The version is 3.20151106.1.

So, I have to say, I am a little bit confused though, since in the Mint 18 release notes it says:

If you are using an ATI GPU in Linux Mint 18, the operating system will either select the Radeon or AMDGPU drivers for you, and these are installed by default.

So shouldn't the drivers have been installed by default?

Anyway, how can I make this work? (I'm trying to avoid downgrading to 17.3 if possible because of UEFI-related issues).

4 Answers 4

2

Lenovo laptops have a dual graphic card, a radeon and an intel one. On battery, they switch to the intel on its low power consumption.

The radeon linux driver is a proprietary, binaryonly software and it is far in quality from the amd cpus. Furthermore, this switch and this dualcard support isn't very well developed in them. But it works.

The radeon driver, being a third party source, has to be enabled in your package manager. Search for synaptic in your start menu, and enable it, then run a system update.

2
  • That makes sense. I installed Mint with third party software enabled though, so I guess it should be there. I do have two questions. What do I check in synaptic to be sure it's enabled? If I type radeon in synaptic, a bunch of things appear (like I said, I'm a newbie when it comes to hardware). And how can I really tell which graphics card is in use?
    – TomCho
    Feb 18, 2017 at 19:00
  • In case it's important: the only one of those options for radeon in synaptic that's installed in xserver-xorg-video-radeon. And I checked the outputs of the commands I listed in my question with the laptop connected to the power and the outputs are still the same.
    – TomCho
    Feb 18, 2017 at 20:09
1
+500

In reply to xralf's bounty message:
Your card is listed as Sun LE [Radeon HD 8550M / R5 M230] which means it's part of the "Solar System" family and based on GCN2 architecture:

Sun: Mainstream part based on second-generation GCN

I recommend the following:

  1. Double check your AMD GPU is correctly detected by the OS. Running lspci | grep VGA is the wrong way to do it since the pci device class 03 (Display controller) has several device subclasses with different names. So either run lspci | grep -E '(VGA|3D|Display)' or simply run lspci and inspect the output. You should have a line like this:

    03:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Renoir (rev c6)
    

    Note that 03:00.0 is the BDF (bus:device.function) which identifies your device.

  2. Determine which driver is used by the OS for your GPU. You can do that with lspci -k -s BDF e.g. on my setup lspci -k -s 03:00.0 prints

    03:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Renoir (rev c6)
            Subsystem: Tongfang Hongkong Limited Renoir
            Kernel driver in use: amdgpu
            Kernel modules: amdgpu
    

    In my case the driver used is amdgpu but in your case, at least based on your lshw output, the driver used is radeon. So the output in your case might be:

            Kernel driver in use: radeon
            Kernel modules: radeon, amdgpu
    
  3. Instruct the kernel to use the amdgpu driver instead of radeon. Add the following parameters to your kernel boot line:

    radeon.cik_support=0 amdgpu.cik_support=1 amdgpu.modeset=1
    

    the last one (the modeset) might not be needed, you can experiment and see if it works without it. From what I gather e.g. (1), (2), (3) that's all that's needed on Ubuntu.
    If you want to try that driver without changing your current configuration follow the guide here: Temporarily Add a Kernel Boot Parameter for Testing and add those parameters so you end up with something like:

    ... quiet splash radeon.cik_support=0 amdgpu.cik_support=1 amdgpu.modeset=1
    

    The OS would then boot using the amdgpu driver until you reboot the system.

For the record, ArchWiki has a detailed guide on enabling amdgpu for cards based on GCN/GCN2 architecture (though some of the instructions there are Arch-specific).

2
  • Thank you. To step 3) amdgpu is better than radeon? Which file should I edit? Isn't enough to put export DRI_PRIME=1 to my ~/.profile?
    – xralf
    Nov 30, 2023 at 20:59
  • 1
    @xralf - DRI_PRIME is to tell the OS which gpu to use (i.e. amd or intel) not which driver. As to the drivers... radeon is for the older cards and amdgpu for newer cards... yours is in-between. Phoronix has a good article about this and some benchmarks. As you can see there's no big difference, a 10-15% difference in most cases. Your card is on the low end of the spectrum so I don't think you will notice a big improvement. However, you can always try it without modifying any file, via grub edit, see my post edit (last paragraph) Nov 30, 2023 at 21:45
0

Seems that you have 2 graphics cards in your computer one Intel and Radeon. If you like you can use the intel drivers that works fine. https://01.org/linuxgraphics

I think the installation of this driver is going to configure all X11 stuff.

2
  • The things is that the Intel graphics are integrated in the motherboard, so not very good. The Radeon card is dedicated, so I'd like it to be the one used. How do I use that one?
    – TomCho
    Feb 18, 2017 at 18:53
  • I have the same problem. please suggest how can i enable radeon card for my linux mint 18. Oct 6, 2017 at 6:05
0

Unfortunately, none of the suggestions worked. I read a lot about it and apparently there's just no way. So the answer for this question is: you can't have the Radeon R5 M230 in Mint 18.1 because the support for this version of Ubuntu is dropped (unless maybe you do something really invasive to your system).

The only solution I found to make it work was downgrading to Linux Mint 17.3 and following this awesome answer

EDIT

Since this question has been viewed a lot I think it deserves an edit at this point.

Since I asked the question some development has been made for AMD support in linux. A few weeks ago I installed Mint 18.2 in a computer with a dual Intel/Radeon R5 graphics with the most up-to-date kernel, which at the time was 4.12.

It wasn't my computer so I didn't have the chance to test it properly, but it appears that the system recognized the Radeon card right after the kernel update (I didn't do anything card-related). So I'm guessing as of now the chances of it working are much better.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .