1

Hi for the reason here, I would like to install glibc in my own directory. I tried to follow the "HOWTO" here

wget http://ftp.gnu.org/gnu/libc/glibc-2.7.tar.gz
tar xzvf glibc-2.7.tar.gz
wget https://ftp.gnu.org/gnu/libc/glibc-linuxthreads-2.5.tar.bz2 # this version looks old, but this is the most recent source I could find. 
cp glibc-linuxthreads-2.5.tar.bz2 glibc-2.24
cd glibc-2.7
tar xvjf glibc-linuxthreads-2.5.tar.bz2 
cd ..
mkdir glibc-build
cd glibc-build
~/Tool/glibc-2.7/configure --enable-add-ons=linuxthreads --prefix=$HOME/Programme/glibc
    checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
configure: running configure fragment for add-on linuxthreads
checking sysdep dirs... sysdeps/x86_64/elf linuxthreads/sysdeps/unix/sysv/linux/x86_64 sysdeps/unix/sysv/linux/x86_64 sysdeps/unix/sysv/linux/wordsize-64 linuxthreads/sysdeps/unix/sysv/linux linuxthreads/sysdeps/pthread sysdeps/pthread sysdeps/unix/sysv/linux sysdeps/gnu sysdeps/unix/common sysdeps/unix/mman sysdeps/unix/inet linuxthreads/sysdeps/unix/sysv sysdeps/unix/sysv sysdeps/unix/x86_64 linuxthreads/sysdeps/unix sysdeps/unix sysdeps/posix sysdeps/x86_64/fpu linuxthreads/sysdeps/x86_64 sysdeps/x86_64 sysdeps/wordsize-64 sysdeps/ieee754/ldbl-96 sysdeps/ieee754/dbl-64 sysdeps/ieee754/flt-32 sysdeps/ieee754 sysdeps/generic/elf sysdeps/generic
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking for gcc... gcc
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for ranlib... ranlib
checking whether as is GNU as... yes
checking whether ld is GNU ld... yes
checking for as... as
checking version of as... 2.17.50.0.6, ok
checking for ld... ld
checking version of ld... 2.17.50.0.6, ok
checking for pwd... /bin/pwd
checking for gcc... gcc
checking version of gcc... 6.1.0, bad
checking for gnumake... no
checking for gmake... gmake
checking version of gmake... 3.81, ok
checking for gnumsgfmt... no
checking for gmsgfmt... no
checking for msgfmt... msgfmt
checking version of msgfmt... 0.17, ok
checking for makeinfo... makeinfo
checking version of makeinfo... 4.8, ok
checking for sed... sed
checking version of sed... 4.1.5, ok
checking for autoconf... autoconf
checking whether autoconf works... yes
configure: error:
*** These critical programs are missing or too old: gcc
*** Check the INSTALL file for required versions.

but my version of gcc:

gcc --version
gcc (GCC) 6.1.0
Copyright (C) 2016 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

which is a more recent version compared with the version required in the "INSTALL" file:

  * GCC 3.4 or newer, GCC 4.1 recommended

Any suggestion to solved the issue, or suggestion about any mistake I have made?

1
  • 2
    gcc 6 is too new. Try gcc 4.1 as suggested. Feb 18 '17 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.