1

I'm on OSX using iTerm (3) with prezto as my zsh configuration framework. I've a strange error message when I use rsync:

$ rsync -avz --exclude='.git' src/ remote:/dst
bash: rsync: command not found
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at /BuildRoot/Library/Caches/com.apple.xbs/Sources/rsync/rsync-51/rsync/io.c(453) [sender=2.6.9]

When I check the path to rsync I see:

$ which rsync
rsync: aliased to noglob rsync
$ type -a rsync
rsync is an alias for noglob rsync
rsync is /usr/bin/rsync

It seems that it's an alias declared by prezto that uses the noglob macro. I also tried to call the rsync command with /usr/bin/rsync but didn't help.

Any idea what's wrong here??

closed as off-topic by Jeff Schaller, countermode, Anthon, thrig, Zachary Brady Feb 17 '17 at 16:21

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, countermode, Anthon, thrig, Zachary Brady
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What is the output of type -a rsync ? – terdon Feb 17 '17 at 10:41
  • I updated the post with the result of type -a rsync. – bachr Feb 17 '17 at 10:45
  • rsync: command not found. Dude ... – SYN Feb 17 '17 at 12:53
5

It turns out rsync has to be installed on the remote machine. I just did and now it works fine.

Not the answer you're looking for? Browse other questions tagged or ask your own question.