1

I have used following commands to install java.

 wget --no-cookies --no-check-certificate --header "Cookie: gpw_e24=http%3A%2F%2Fwww.oracle.com%2F; oraclelicense=accept-securebackup-cookie" "http://download.oracle.com/otn-pub/java/jdk/8u112-b15/jdk-8u112-linux-x64.rpm"

After that yum install jdk-8u112-linux-x64.rpm

Now i downloaded the jboss

wget http://download.jboss.org/jbossas/7.1/jboss-as-7.1.1.Final/jboss-as-7.1.1.Final.zip

after that unziped it

unzip jboss-as-7.1.1.Final.zip
I have placed jboss in /opt/jboss-as-7.1.1.Final directory

after that i have used following commands

 adduser jboss
 chown -fR jboss.jboss /opt/jboss-as-7.1.1.Final/
 su jboss

also i saved that path using the command

export JAVA_HOME=/usr/java/jdk1.8.0_112/
export PATH=$PATH:$JAVA_HOME/bin

Actually i am following these steps from a tutorial and in the last when i am running the standalone.sh file its showing following lines and not moving beyond this, please help its is not moving beyond this

    [jboss@centos_pc2 bin]$ ./standalone.sh 
=========================================================================

  JBoss Bootstrap Environment

  JBOSS_HOME: /opt/jboss-as

  JAVA: /usr/java/jdk1.8.0_112//bin/java

  JAVA_OPTS:  -server -XX:+UseCompressedOops -XX:+TieredCompilation -Xms64m -Xmx1024m -XX:MaxPermSize=512m -Djava.net.preferIPv4Stack=true -Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true -Djboss.server.default.config=standalone.xml

=========================================================================

Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=512m; support was removed in 8.0
12:47:33,368 INFO  [org.jboss.modules] JBoss Modules version 1.1.1.GA
12:47:33,608 INFO  [org.jboss.msc] JBoss MSC version 1.0.2.GA
12:47:33,679 INFO  [org.jboss.as] JBAS015899: JBoss AS 7.1.1.Final "Brontes" starting
1

All you need is to change to Java version 7 or 6 and then try to start JBoss again.

  • [root@centos_pc2 ~]# java -version openjdk version "1.8.0_121" OpenJDK Runtime Environment (build 1.8.0_121-b13) OpenJDK 64-Bit Server VM (build 25.121-b13, mixed mode) – harsh sharma Feb 16 '17 at 9:14
  • Try java version 1.7 or 1.6 – Ali Golestan Feb 16 '17 at 9:15
  • please tell how to change java version from 1.8 to 1.7. When i am installing java 1.7, it replying that latest version of 1.7 has already been installed. – harsh sharma Feb 16 '17 at 9:15
  • Try downloading and installing the specific version from Java downloads, then change the Java home path – Ali Golestan Feb 16 '17 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.