1

I have a recent problem with my sound configuration. Basically, it's way too loud until I set the volume below 10%. And then it's very quickly too silent. Using the alsa mixer, I can set the headphone volume and PCM volume to about 50% and then obtain a reasonable range on the master. But any application using pulse will reset all the non-master channels to max and kill my ears instantly.

Is there a way to force pulse to NOT change the other channels? I tried to look for information, and it seems that I need to change the channels from "mixin" to "ignore" in the configuration file, but there are so many configuration files, and I haven't found which ones are actually used by my system. So in the end, I am not even sure that what I think is correct.

Can someone tell me: how to find the exact configuration files I need to change, or how to override the global configuration with some local one? and what I need to actually change?

Thanks.

2 Answers 2

1

The file

/usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common

contains all the explanations and the basic settings on how pulseaudio will tinker with Alsa Mixer settings.

0

So in the end, I figured out that my profile was called analog-output-headphones. And the relevant configuration file is there:

/usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf

For some reason, the configuration of my alsa card is such that the master volume doesn't do anything and I haven't found how to change that. But I can "ignore" the master and only act on the headphones ... This is not ideal, but currently works.

1
  • Note for anyone else stumbling across this: the order of the [Element entries in those files determines the order in which PulseAudio will prioritize fiddling with the mixers…you can shuffle them around if you want (e.g., putting the "outer" mixers that are bound to the ports themselves at the top) Apr 12, 2020 at 16:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .