4

I have an old Sun Blade 1500, with a Ultrasparc IIIi 1.5 GHz, 2GB ECC RAM. SunOS 5.10, ufs filesystem. The hardware (MB, HDD and video card) is failing on me and I'm searching for a way to emulate it on x86 hardware. I have a DD raw copy of the HDD that I tried to mount it on Linux but i'm getting: disk cannot be accessed. I read about emulating it with qemu but I don't have much experience with Sun/Solaris and Linux environments. Has anyone tried and succeeded emulating a system like this? Thank you

8
  • What have you tried so far? What mount command did you use, and what was its output? Linux itself can read ufs. Note that you generally want to specify an offset (to the partition itself) when trying to mount a raw disk image. Further note: Sun uses a BSD-style disklabel, rather than the typical Linux MBR or GPT, which may or may not make things more difficult.
    – Fox
    Feb 15 '17 at 9:12
  • and emulating SPARC hardware on x86 is likely doomed. Buying a Sun Blade 1500 on eBay or whatever would probably be your best option.
    – jlliagre
    Feb 15 '17 at 9:23
  • @jlliagre Qemu's SPARC emulation is actually pretty good... Feb 15 '17 at 10:47
  • 1
    @StephenKitt I have no doubt SPARC CPU emulation by qemu is good. The issue here is not only emulating CPU but a full SPARC server with its devices close enough for being able to boot a disk image, especially by someone with no experience with Sun/Solaris.
    – jlliagre
    Feb 15 '17 at 10:52
  • @jlliagre good point, device tree discrepancies can usually be resolved during the boot but you do need to know your way around Qemu, OBP and Solaris... Feb 15 '17 at 11:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.