2

I want use php_intl.dll in /etc/opt/remi/php70/ini.php. So how to install this extension. I use centos7

3

You cannot install a windows .dll on Linux OS

To install php_intl on CentOS , you should enable remi repo . Open the terminal and run the following commands:

wget https://rhel7.iuscommunity.org/ius-release.rpm
sudo rpm -Uvh ius-release*.rpm

Update your system then install the php-intl:

sudo yum update
sudo yum --enablerepo=remi install php-intl

To permanently enable remi repo , open the terminal and run the following command:

sudo nano /etc/yum.repos.d/remi.repo

Set enabled=1.

0

There are two ways to install php-intl in centos-os (centos ver 2017.09), php version > 7.0

  1. Update system, and try install php-intl directly
  2. Install php-intl through IUS and REMI repositories

1. Update system, and try install php-intl directly

UPDATE SYSTEM command
sudo yum update

INSTALL php70-intl extension
sudo yum install -y php70-intl

2. Install php-intl through IUS and REMI repositories

INSTALL IUS repository (http://iuscommunity.org/pages/Repos.html#release-packages)
cd /opt/
sudo wget https://rhel7.iuscommunity.org/ius-release.rpm
sudo rpm -Uvh ius-release*.rpm

If getting epel error like epel-release = 7 is needed by ius-release-1.0-15.ius.el7.noarch you need to install epel-7 through following command, and retry above command

sudo rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
Update system via
sudo yum update

Retry ius install
sudo rpm -Uvh ius-release*.rpm

After IUS is successfully installed, run update system again through command sudo yum update

INSTALL php-intl THROUGH REMI REPOSITORY

Enable remi (temporarily) and install php-intl
sudo yum --enablerepo=remi install php-intl

IF getting ERROR like "Error getting repository data for remi, repository not found", you need to install remi repository first, then run above command

yum install http://rpms.remirepo.net/enterprise/remi-release-7.rpm

IF getting ERROR like "php70-common-7.0.32-1.31.amzn1.x86_64 conflicts php-common < 5.5.22-1.98" then you need to install php70-intl directly in place of remi repository

sudo yum install -y php70-intl

  • No package php70-intl available. – Utku Dalmaz May 14 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.