2

I run arch linux and recently upgraded to kernel 4.6.9. Upon reboot, I was dumped into single user mode, with an error message that indicates a missing codepage, specifically codepage 437. I did some research, and it looks like cp437 is used to identify FAT file systems. I checked the options my kernel was compiled with (it is the default arch kernel) and CONFIG_NLS_CODEPAGE_437 was compiled as a module and CONFIG_FAT_DEFAULT_CODEPAGE was set to 437. The error dmesg gives is this: FAT-fs (sdc1): codepage cp437 not found. /dev/sdc1 is my UEFI boot partition and is stored on a removable usb drive. I am unable to move beyond single user mode, which I find strange because the only volume I am not able to mount is the UEFI partition (I have tried mount it with the mount command, even specified the codepage).

I looked for answers on the arch linux bbs. What I have tried so far is mounting all of my drives and partitions to a live iso of arch and upgrading the entire system. I have read that recompiling the kernel may solve the issue but it seems like the necessary code was already compiled in. I am willing to try if need be. Any help is appreciated!

  • The module should be on the initramfs. It sounds like something went wrong when upgrading the kernel and the initramfs wasn't regenerated properly. Check the wiki, maybe it has a recovery procedure that could work for you. – Gilles 'SO- stop being evil' Feb 15 '17 at 22:50
  • Yes that worked! I am able to boot into multi-user mode (my default mode). Seems like quiet mode was enabled on boot, didn't get any status messages, and gdm hangs when I start it, but at least I'm not stuck in single-user mode. Thanks! – vespid Feb 16 '17 at 21:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.