0

Environment: VPS, CentOS7, glassfish3, server is running.

Tried: both in root and glassfish user. a comamnd: "startNetworkServer" and sudo netstat -lntp | grep 1527 nothing happened so it seems port is free.

goal: to start database in glassfish server

I searched over and over but couldnt find any solution. I am trying to deploy my web app on glassfish server in CentOS7. As my web app uses databases, i have to start a database so i hit this command in "bin" directory,

./asadmin start-database

but i get

Starting database in Network Server mode on host 0.0.0.0 and port 1527. Unable to start database. Please check log in /opt/glassfish3/glassfish/databases/derby.log. Command start-database failed.

I dont understand why i get this error. when i see derby.log, nothing was written. I am completely stuck now. I hope I can get your help.

Thanks.

0

glassfish3 was causing this problem. i installed 4 and worked well.

  • Could you please elaborate your answer. – Thomas Feb 14 '17 at 11:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.