0

So I was following the answered instructions here, How to install CUDA Toolkit 7.x or 8 on Debian 8 (Jessie) or 9 (Stretch)? and I get the following error when I run the .run file:

gzip: stdin: invalid compressed data--format violated
Extraction failed.
Ensure there is enough space in /tmp and that the installation package is not corrupt
Signal caught, cleaning up

I get the same error when I run under both sudo and non-sudo. I have also tried running it with the option --tmpdir, where I set the location to be in my home folder and I got the same error. So then I thought that maybe the download was somehow corrupted. So when I checked the md5 using:

md5sum cuda_8.0.61_375.26_linux.run

I get 416979dd6df6fe601d99facd0cfe2874, while the checksum provided by nvidia is

33e1bd980e91af4e55f3ef835c103f9b cuda_8.0.61_375.26_linux.run

I then tried downloaded it and checking the checksum on the following: Chromium (same system), Firefox (same system), wget (same system), Chrome (windows), and wget (different system provided by my uni) and they all returned the same checksum.

So from my above testing, it looks like the installer may be corrupt? Anyone have any ideas on how to fix this. Thanks.

0

yes, the installer is broken and seems to be repaired by Nvidia right now

see https://devtalk.nvidia.com/default/topic/993274/cuda-setup-and-installation/bad-checksum-for-cuda-8-0-for-ubuntu-14-04/1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.