2

I have a problem getting proprietary Nvidia driver to work on Linux Mint with multiple monitors correctly. In the following I give a brief introduction to what I have tried and how far I got:

I have a Dell Precision M6600 with Nvidia Quadro K3000M graphics card. M6600 sits on the Dell docking station to which my other monitor Dell U2515H is connected via displayport.

I did a fresh install of Linux Mint 18.1 and everything looked fine. Even the two monitors seemed to work in extended desktop mode out of the box.

photo showing both screens working

Screenshot of display settings

Screenshot of driver manager tool

I set the U2515H to be to the left of the laptop display to reflect their physical positioning.

Screenshot of display settings after changing monitor positioning

Photo of resulting screen layout

After saving the settings and restarting Linux Mint 18.1 did not seem to retain the saved settings and placed the U2515H back to the right side of the laptop display. But that's not the main issue here.

The usage of open source graphics driver did result in some artifacts (trailing mouse pointer etc.) on the screen so I guessed it might be a driver problem. I opened the Driver Manager and applied the nvidia-367 driver as it was listed and also recommended there.

Screenshot of driver tool showing the proprietary driver selected

After restarting the laptop the U2515H was not showing anything, only the laptop screen was detected. Trying to change the laptops display mode with Fn+F8 did not do anything.

Screenshot of display settings showing only 1 screen

robert@Robert-Precision-M6600 ~ $ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
LVDS1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
   1920x1080     60.01*+  59.93    40.01  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1600x900      60.00  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1368x768      60.00  
   1360x768      59.80    59.96  
   1152x864      60.00  
   1280x720      60.00  
   1024x768      60.00  
   1024x576      60.00  
   960x540       60.00  
   800x600       60.32    56.25  
   864x486       60.00  
   640x480       59.94  
   720x405       60.00  
   640x360       60.00  
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

As I was stuck and didn't know what to do I decided to try other driver versions. I did sudo apt-get purge nvidia* -> sudo add-apt-repository ppa:graphics-drivers/ppa -> sudo apt-get update as per this article NVIDIA: how to install the latest video card drivers. Then I opened Driver Manager again and chose the newest supported driver:

Driver tool screenshot

Nvidia Quadro Driver Release 378 supports my Quadro K3000M.

After restarting the issue was still there although it seemed in the Driver Manager that the driver had been installed. But looking at lsmod output:

robert@Robert-Precision-M6600 ~ $ lsmod | grep nvidia
robert@Robert-Precision-M6600 ~ $ lsmod | grep nouveau
nouveau              1495040  0
mxm_wmi                16384  1 nouveau
ttm                    94208  1 nouveau
i2c_algo_bit           16384  2 i915,nouveau
drm_kms_helper        155648  2 i915,nouveau
drm                   364544  8 ttm,i915,drm_kms_helper,nouveau
wmi                    20480  3 dell_wmi,mxm_wmi,nouveau
video                  40960  4 i915,dell_wmi,nouveau,dell_laptop

... and Nvidia X Server settings:

Screenshot of Nvidia X Server settings

... it seems open source driver is still in use.

I chose the Nvidia (Performance mode) and it asked me to log out to apply the changes which I did. After logging in again I opened Nvidia X Server settings and it was defaulted to Intel (Power Saving Mode) again no matter how many times I tried to apply Nvidia (Performance mode) and logging out and in again.

I decided to try the nvidia-375 driver listed in Driver Manager. Did the apply -> restart but still no luck. Nvidia X Server GUI output was the same as before, same with lsmod | grep nvidia and lsmod | grep nouveau. It seems the open source driver is still in use.

I also tried the nvidia-370 driver listes in Driver Manager, but the result is the same. I have no idea what to do next, which logs entries to look for and where?

I did grep "nvidia" /var/log/syslog and the output is HERE

In short I would like to get the extended desktop mode to work with Nvidia proprietary driver. After a whole day wasted I'm out of ideas. As I'm not a linux guru I lack the knowledge to debug this issue by myself I was hoping maybe someone smarter could help me with it if they have the time and will. Thank you in advance!

> EDIT #1

Tried to do sudo nvidia-settings as suggested by @trendon to try to forcefully apply Nvidia (Performance mode). Logged out -> logged in. Nothing changed. Although sudo nvidia-settings gave the following output:

robert@Robert-Precision-M6600 ~ $ sudo nvidia-settings
[sudo] password for robert: 

ERROR: Error querying enabled displays on GPU 0 (Missing Extension).


ERROR: Error querying connected displays on GPU 0 (Missing Extension).

** Message: PRIME: No offloading required. Abort
** Message: PRIME: is it supported? no

ERROR: nvidia-settings could not find the registry key file. This file should
       have been installed along with this driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       prepopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.

Also went into BIOS, searched for option to disable Intel's graphics but there was none. I was only able to disable Nvidia Optimus Technology so for the sake of trying anything I did that. Booted into linux. Everything was back to the beginning - both monitors worked in extended desktop mode using the open source driver. Now xrandr detected my other monitor aswell which wasn't the case before when I applied the Nvidia driver the first time:

robert@Robert-Precision-M6600 ~ $ xrandr
Screen 0: minimum 8 x 8, current 4480 x 1440, maximum 32767 x 32767
LVDS1 connected primary 1920x1080+2560+360 (normal left inverted right x axis y axis) 382mm x 215mm
   1920x1080     60.01*+  59.93    40.01  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1600x900      60.00  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1368x768      60.00  
   1360x768      59.80    59.96  
   1152x864      60.00  
   1280x720      60.00  
   1024x768      60.00  
   1024x576      60.00  
   960x540       60.00  
   800x600       60.32    56.25  
   864x486       60.00  
   640x480       59.94  
   720x405       60.00  
   640x360       60.00  
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
DP-1-1 disconnected
DP-1-2 disconnected
DP-1-3 connected 2560x1440+0+0 553mm x 311mm
   2560x1440     59.95*+
   2048x1152     60.00  
   1920x1200     59.88  
   1920x1080     60.00    50.00    59.94    30.00    25.00    24.00    29.97    23.98  
   1920x1080i    60.00    50.00    59.94  
   1600x1200     60.00  
   1680x1050     59.95  
   1280x1024     75.02    60.02  
   1200x960      59.99  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.08    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x576i      50.00  
   720x480       60.00    59.94  
   720x480i      60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
  1680x1050 (0x56) 146.250MHz -HSync +VSync
        h: width  1680 start 1784 end 1960 total 2240 skew    0 clock  65.29KHz
        v: height 1050 start 1053 end 1059 total 1089           clock  59.95Hz
  1280x1024 (0x58) 108.000MHz +HSync +VSync
        h: width  1280 start 1328 end 1440 total 1688 skew    0 clock  63.98KHz
        v: height 1024 start 1025 end 1028 total 1066           clock  60.02Hz
  1024x768 (0x5f) 65.000MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock  48.36KHz
        v: height  768 start  771 end  777 total  806           clock  60.00Hz
  800x600 (0x61) 40.000MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock  37.88KHz
        v: height  600 start  601 end  605 total  628           clock  60.32Hz
  640x480 (0x6a) 25.175MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock  31.47KHz
        v: height  480 start  490 end  492 total  525           clock  59.94Hz

Went into Driver Manager. Applied the latest Nvidia driver (nvidia-378). Shutdown. Went into BIOS and enabled Nvidia Optimus Technology. Booted into linux. Nvidia driver still not working. lsmod | grep nvidia did not give any output. Driver Manager window states at the bottom left corner that No proprietary drivers are in use although the nvidia-378 driver is selected active state.

> EDIT #2

inxi -Gxz output:

Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GK104GLM [Quadro K3000M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1920x1080@60.01hz, 2560x1440@59.95hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 12.0.6 Direct Rendering: Yes

cat /var/log/Xorg.0.log output (pastebin)

cat /home/robert/.xsession-errors output (pastebin)

migrated from stackoverflow.com Feb 12 '17 at 12:31

This question came from our site for professional and enthusiast programmers.

  • 1
    Welcome to Unix & Linux! Thanks for the comprehensive question, but please don't post screenshots of text. Instead, paste the text directly into your question and use the formatting tools. Please edit your question and post the text output of the two commands you show, as well as the output of the grep "nvidia" /var/log/syslog command. – terdon Feb 12 '17 at 13:12
  • Does it work if you run the nvidia tool as root (sudo nvidia-settings) then save? I haven't had a dual GPU machine in a while, but last time I did, I had to disable the onboard (intel) chip in the BIOS. That might be worth a try, although Bumblebee is supposed to have improved in recent years. – terdon Feb 12 '17 at 13:18
  • @terdon Thank you for helping. Made the edits you suggested although the grep "nvidia" /var/log/syslog output is way too lenghty to be included in the post. Tried your suggestions -> see my post EDIT #1. – Robert Feb 12 '17 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.