1

I have recently purchased VPS and I installed LAMP on it. When I access Phpmyadmin through browser it asks login and password. Even if I insert wrong password I can login successfully. I even checked it in another PC with other network, I was allowed to login.

So, how can I make a change in such a way that wrong password and login combination don't allow user to log in.

Note: I have installed fail2ban and iptables in the server.
Checked in the phpmyadmin config file

/etc/panel/configs/phpmyadmin/config.inc.php

but could not find

$cfg['Servers'][$i]['AllowNoPassword'] = TRUE;
4
  • 1
    Please look for another line like if (!empty($dbname)) { // other configuration options $cfg['Servers'][$i]['AllowNoPassword'] = TRUE; // it should be placed before the following line $i++; } – George Udosen Feb 12 '17 at 9:50
  • @george that should probably be the answer, not a comment, straight away. – Zlatko Feb 13 '17 at 9:44
  • @george should I put $cfg['Servers'][$i]['AllowNoPassword'] = FALSE; before $i++; ?? – Dipti Sharma Feb 16 '17 at 5:18
  • Yes I believe that should be the case... – George Udosen Feb 16 '17 at 6:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.